zoukankan      html  css  js  c++  java
  • hdu3549 Flow Problem(裸最大流)

                                                  Flow Problem
    Time Limit:5000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

    Description

    Network flow is a well-known difficult problem for ACMers. Given a graph, your task is to find out the maximum flow for the weighted directed graph.
     

    Input

    The first line of input contains an integer T, denoting the number of test cases.
    For each test case, the first line contains two integers N and M, denoting the number of vertexes and edges in the graph. (2 <= N <= 15, 0 <= M <= 1000)
    Next M lines, each line contains three integers X, Y and C, there is an edge from X to Y and the capacity of it is C. (1 <= X, Y <= N, 1 <= C <= 1000)
     

    Output

    For each test cases, you should output the maximum flow from source 1 to sink N.
     

    Sample Input

    2 3 2 1 2 1 2 3 1 3 3 1 2 1 2 3 1 1 3 1
     

    Sample Output

    Case 1: 1

    Case 2: 2


    题目比较简单,入门级最大流问题。

    #include<cstdio>
    #include<algorithm>
    #include<queue>
    #include<string.h>
    #define MAXN 21
    #define INF 1<<28

    using namespace std;

    int cap[MAXN][MAXN], pre[MAXN], vis[MAXN], maxflow[MAXN];
    int Maxflow;
    int n, m, i, j;

    void init()
    {
        int x, y, z;
        memset(cap, 0sizeof(cap));
        memset(pre, 0sizeof(pre));

        scanf("%d%d", &n, &m);
        for(i=1; i<=m; i++)
        {
            scanf("%d%d%d", &x, &y, &z);
            cap[x][y] += z;//重边
        }
    }

    int min(int a, int b)
    {
        return a>b?b:a;
    }

    int main()
    {
        int T, u, k=1;
        scanf("%d", &T);
        while(T--)
        {

            init();
            queue<int>q;
            Maxflow = 0;

            while(1)
           {
            memset(maxflow, 0sizeof(maxflow));
            memset(vis, 0sizeof(vis));
            maxflow[1] = INF;


            q.push(1);
            while(!q.empty())
            {
                 u = q.front();
                 q.pop();
                 for(int v=1; v<=n; v++)
                 {
                     if(!vis[v] && cap[u][v]>0)
                        {
                            vis[v] = 1;
                            pre[v] = u;
                            q.push(v);
                            maxflow[v] = maxflow[u]<cap[u][v]?maxflow[u]:cap[u][v];
                        }
                 }
            }
            if(maxflow[n]==0break;

            for(int i=n; i!=1; i=pre[i])
            {
                cap[pre[i]][i]-=maxflow[n];
                cap[i][pre[i]]+=maxflow[n];
            }

           Maxflow += maxflow[n];
        }
          printf("Case %d: %d ", k++, Maxflow);
        }
         return 0;
    }
    View Code

    每天训练发现我比别人做的好慢,但是理解的更深刻,如果一开始学一个新知识点就搜模板,那么这样的人是走不远的,毕业之后带走的只有思维,什么荣誉,奖杯都已经不重要了。
  • 相关阅读:
    【费用流】【CODEVS】1227 方格取数2
    【CODEVS】1034 家园
    【BZOJ】1066: [SCOI2007]蜥蜴
    【最大流】【CODEVS】1993 草地排水
    【HDU】2191 多重背包问题
    【TYVJ】1520 树的直径
    【BZOJ】1984 月下“毛景树”
    【BZOJ】1588: [HNOI2002]营业额统计
    【NOI】2004 郁闷的出纳员
    【POJ】2892 Tunnel Warfare
  • 原文地址:https://www.cnblogs.com/6bing/p/3928329.html
Copyright © 2011-2022 走看看