zoukankan      html  css  js  c++  java
  • 1003. Emergency (25)

    As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount of rescue teams in each city and the length of each road between any pair of cities are marked on the map. When there is an emergency call to you from some other city, your job is to lead your men to the place as quickly as possible, and at the mean time, call up as many hands on the way as possible.

    Input

    Each input file contains one test case. For each test case, the first line contains 4 positive integers: N (<= 500) - the number of cities (and the cities are numbered from 0 to N-1), M - the number of roads, C1 and C2 - the cities that you are currently in and that you must save, respectively. The next line contains N integers, where the i-th integer is the number of rescue teams in the i-th city. Then M lines follow, each describes a road with three integers c1, c2 and L, which are the pair of cities connected by a road and the length of that road, respectively. It is guaranteed that there exists at least one path from C1 to C2.

    Output

    For each test case, print in one line two numbers: the number of different shortest paths between C1 and C2, and the maximum amount of rescue teams you can possibly gather.
    All the numbers in a line must be separated by exactly one space, and there is no extra space allowed at the end of a line.

    Sample Input
    5 6 0 2
    1 2 1 5 3
    0 1 1
    0 2 2
    0 3 1
    1 2 1
    2 4 1
    3 4 1
    
    Sample Output
    2 4
    

    dijkstra算法。

    代码:

    #include <iostream>
    #include <cstdio>
    #define inf 0x3fffffff
    using namespace std;
    struct point
    {
        int dis,pathnum,res,sres,vis;
    }s[501];
    int length[501][501];
    int N,M,C1,C2,c1,c2,L;
    int main()
    {
        cin>>N>>M>>C1>>C2;
        for(int i=0;i<N;i++)
            cin>>s[i].res;
    
        for(int i=0;i<N;i++)
        {
            for(int j=0;j<N;j++)
                length[i][j]=inf;
            length[i][i]=0;
        }
    
        for(int i=0;i<M;i++)
        {
            cin>>c1>>c2>>L;
            length[c1][c2]=length[c2][c1]=L;
        }
    
        for(int i=0;i<N;i++)
        {
            s[i].dis=length[C1][i];
        }
    
        s[C1].pathnum=1,s[C1].sres=s[C1].res;
    
        for(int i=0;i<N;i++)
        {
            int mind=inf,mi;///
            for(int j=0;j<N;j++)
            {
                if(s[j].vis==0&&s[j].dis<mind)mind=s[j].dis,mi=j;
            }
            s[mi].vis=1;
            for(int j=0;j<N;j++)
            {
                if(s[j].vis)continue;///
                if(s[j].dis>s[mi].dis+length[mi][j])
                {
                    s[j].pathnum=s[mi].pathnum;
                    s[j].dis=s[mi].dis+length[mi][j];
                    s[j].sres=s[mi].sres+s[j].res;
                }
                else if(s[j].dis==s[mi].dis+length[mi][j])
                {
                    s[j].pathnum+=s[mi].pathnum;
                    if(s[j].sres<s[mi].sres+s[j].res)s[j].sres=s[mi].sres+s[j].res;
                }
            }
        }
        cout<<s[C2].pathnum<<' '<<s[C2].sres<<endl;
    }
  • 相关阅读:
    Django跨域问题
    DOM,jquery,vue
    from和modelform的用法和介绍
    元类的__call__和__new__方法的作用
    Django学习之路由分发和反向解析
    Django 自定义auth_user
    Django创建对象的create和save方法
    Flask--(登录注册)抽取视图函数
    Flask--(项目准备)--添加日志
    Flask--(项目准备)--框架搭建,配置文件抽取,业务逻辑抽取
  • 原文地址:https://www.cnblogs.com/8023spz/p/7290474.html
Copyright © 2011-2022 走看看