zoukankan      html  css  js  c++  java
  • 1013. Battle Over Cities (25)

    It is vitally important to have all the cities connected by highways in a war. If a city is occupied by the enemy, all the highways from/toward that city are closed. We must know immediately if we need to repair any other highways to keep the rest of the cities connected. Given the map of cities which have all the remaining highways marked, you are supposed to tell the number of highways need to be repaired, quickly.

    For example, if we have 3 cities and 2 highways connecting city1-city2 and city1-city3. Then if city1 is occupied by the enemy, we must have 1 highway repaired, that is the highway city2-city3.

    Input

    Each input file contains one test case. Each case starts with a line containing 3 numbers N (<1000), M and K, which are the total number of cities, the number of remaining highways, and the number of cities to be checked, respectively. Then M lines follow, each describes a highway by 2 integers, which are the numbers of the cities the highway connects. The cities are numbered from 1 to N. Finally there is a line containing K numbers, which represent the cities we concern.

    Output

    For each of the K cities, output in a line the number of highways need to be repaired if that city is lost.

    Sample Input
    3 2 3
    1 2
    1 3
    1 2 3
    
    Sample Output
    1
    0
    0
    

    删除某个城市,看看剩下有几个连通子图,如果有n个,就需要n - 1条highways。先判断最初图b个连通子图,每个点肯定只能属于一个连通子图。某个删除了把他所在的图分成了c个连通子图,结果就是b + c - 2。

    代码:

    #include <iostream>
    #include <cstring>
    using namespace std;
    int vis[1001],mp[1001][1001];
    int n,m,k;
    int a,b,c;
    void dfs(int k)
    {
        for(int i = 1;i <= n;i ++)
        {
            if(!vis[i] && mp[k][i])
            {
                vis[i] = 1;
                dfs(i);
            }
        }
    }
    int main()
    {
        cin>>n>>m>>k;
        for(int i = 0;i < m;i ++)
        {
            cin>>a>>b;
            mp[a][b] = mp[b][a] = 1;
        }
        b = 0;
        for(int i = 1;i <= n;i ++)
        {
            if(!vis[i])
            {
                b ++;
                vis[i] = 1;
                dfs(i);
            }
        }
        for(int i = 0;i < k;i ++)
        {
            memset(vis,0,sizeof(vis));
            cin>>a;
            vis[a] = 1;
            c = 0;
            for(int j = 1;j <= n;j ++)
            {
                if(!vis[j] && mp[a][j])
                {
                    c ++;
                    vis[j] = 1;
                    dfs(j);
                }
            }
            cout<<c - 1 + b - 1<<endl;
        }
    }
  • 相关阅读:
    微服务架构
    SQL语句优化方法30例(转)
    Repeater后台取前台textbox值
    JAVAJDK环境变量的配置(转)
    [转]javascript把数字格式化转换成货币型
    改变ascx的pageLoad和页面的pageLoad执行顺序(转)
    关于在Webservice里使用LinqToSQL遇到一对多关系的父子表中子表需要ToList输出泛型而产生循环引用错误的解决办法!(转)
    兼容IE,FILEFOX的JS 全选(转)
    Android xml 布局(转)
    LINQ to SQL Transaction(转)
  • 原文地址:https://www.cnblogs.com/8023spz/p/7942985.html
Copyright © 2011-2022 走看看