zoukankan      html  css  js  c++  java
  • 1020. Tree Traversals (25)

    Suppose that all the keys in a binary tree are distinct positive integers. Given the postorder and inorder traversal sequences, you are supposed to output the level order traversal sequence of the corresponding binary tree.

    Input Specification:

    Each input file contains one test case. For each case, the first line gives a positive integer N (<=30), the total number of nodes in the binary tree. The second line gives the postorder sequence and the third line gives the inorder sequence. All the numbers in a line are separated by a space.

    Output Specification:

    For each test case, print in one line the level order traversal sequence of the corresponding binary tree. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

    Sample Input:
    7
    2 3 1 5 7 6 4
    1 2 3 4 5 6 7
    
    Sample Output:
    4 1 6 3 5 7 2
    

    代码:

    #include <iostream>
    #include <cstring>
    #include <queue>
    using namespace std;
    struct TNode
    {
        int Data;
        TNode *Left,*Right;
    };
    int h[30],z[30],n;
    TNode *CreatTNode()
    {
        TNode *p = new TNode();
        p -> Left = p -> Right = NULL;
        return p;
    }
    TNode *RestoreTree(int z1,int z2,int h1,int h2)
    {
        TNode *head = CreatTNode();
        head -> Data = h[h2];
        for(int i = z2;i >= z1;i --)
        {
            if(z[i] == h[h2])
            {
                if(i != z1)head -> Left = RestoreTree(z1,i - 1,h1,h1 + i - z1 - 1);
                if(i != z2)head -> Right = RestoreTree(i + 1,z2,h1 + i - z1,h2 - 1);
                break;
            }
        }
        return head;
    }
    void levelOrder(TNode *head)
    {
        int flag = 0;
        queue<TNode *>q;
        q.push(head);
        while(!q.empty())
        {
            if(q.front() -> Left)q.push(q.front() -> Left);
            if(q.front() -> Right)q.push(q.front() -> Right);
            if(flag)cout<<' '<<q.front() -> Data;
            else
            {
                flag = 1;
                cout<<q.front() -> Data;
            }
            q.pop();
        }
    }
    int main()
    {
        cin>>n;
        for(int i = 0;i < n;i ++)
        {
            cin>>h[i];
        }
        for(int i = 0;i < n;i ++)
        {
            cin>>z[i];
        }
        TNode *head = RestoreTree(0,n - 1,0,n - 1);
        levelOrder(head);
    }
  • 相关阅读:
    NoSuchElementException if input is exhausted 报错
    批量更改文件后缀名
    初识Java
    简单cmd
    电脑操作简易快捷键
    java学习 Markdown+开始写博客
    JavaScript基础知识
    当数位数不够这,前面补0
    vs code 设置
    json日期格式转换为 2019-11-27 格式
  • 原文地址:https://www.cnblogs.com/8023spz/p/7943158.html
Copyright © 2011-2022 走看看