zoukankan      html  css  js  c++  java
  • 1039. Course List for Student (25)

    Zhejiang University has 40000 students and provides 2500 courses. Now given the student name lists of all the courses, you are supposed to output the registered course list for each student who comes for a query.

    Input Specification:

    Each input file contains one test case. For each case, the first line contains 2 positive integers: N (<=40000), the number of students who look for their course lists, and K (<=2500), the total number of courses. Then the student name lists are given for the courses (numbered from 1 to K) in the following format: for each course i, first the course index i and the number of registered students Ni (<= 200) are given in a line. Then in the next line, Ni student names are given. A student name consists of 3 capital English letters plus a one-digit number. Finally the last line contains the N names of students who come for a query. All the names and numbers in a line are separated by a space.

    Output Specification:

    For each test case, print your results in N lines. Each line corresponds to one student, in the following format: first print the student's name, then the total number of registered courses of that student, and finally the indices of the courses in increasing order. The query results must be printed in the same order as input. All the data in a line must be separated by a space, with no extra space at the end of the line.

    Sample Input:
    11 5
    4 7
    BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
    1 4
    ANN0 BOB5 JAY9 LOR6
    2 7
    ANN0 BOB5 FRA8 JAY9 JOE4 KAT3 LOR6
    3 1
    BOB5
    5 9
    AMY7 ANN0 BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
    ZOE1 ANN0 BOB5 JOE4 JAY9 FRA8 DON2 AMY7 KAT3 LOR6 NON9
    
    Sample Output:
    ZOE1 2 4 5
    ANN0 3 1 2 5
    BOB5 5 1 2 3 4 5
    JOE4 1 2
    JAY9 4 1 2 4 5
    FRA8 3 2 4 5
    DON2 2 4 5
    AMY7 1 5
    KAT3 3 2 4 5
    LOR6 4 1 2 4 5
    NON9 0
    

    本来想就是一个排序的题目,可是最后一个测试点总是超时,map不管用了,还好题目中的名字只有四个字符,可以创造一个映射。

    代码:
    #include <iostream>
    #include <algorithm>
    #include <cstdio>
    #include <map>
    using namespace std;
    struct node
    {
        int data;
        node *next;
    }*stu[400001];
    node *creat()
    {
        node *p = new node();
        p -> next = NULL;
        return p;
    }
    void insert_node(node *t,int s)
    {
        while(t -> next && t -> next -> data < s)
            t = t -> next;
        node *p = creat();
        p -> data = s;
        if(t -> next)
        {
            p -> next = t -> next;
        }
        t -> next = p;
    }
    int q[26*26*26*26*10];
    int getnum(char* p)
    {
        return (p[0] - 'A')*26*26*26 + (p[1] - 'A')*26*26 + (p[2] - 'A')*26 + (p[3] - '0');
    }
    int main()
    {
        int n,k,pre,m,no = 1;
        char peo[5];
        scanf("%d%d",&n,&k);
        stu[0] = creat();///未录入的设置为0通过map指向stu[0]
        stu[0] -> data = 0;
        for(int i = 0;i < k;i ++)
        {
            scanf("%d%d",&pre,&m);
            for(int j = 0;j < m;j ++)
            {
                scanf("%s",peo);
                if(q[getnum(peo)] == 0)
                {
                    q[getnum(peo)] = no ++;
                    stu[no - 1] = creat();
                    stu[no - 1] -> data = 0;
                }
                (stu[q[getnum(peo)]] -> data) ++;
                insert_node(stu[q[getnum(peo)]],pre);
            }
        }
        for(int i = 0;i < n;i ++)
        {
            scanf("%s",peo);
            printf("%s %d",peo,stu[q[getnum(peo)]] -> data);
            for(node *head = stu[q[getnum(peo)]] -> next;head != NULL;head = head -> next)
            {
                printf(" %d",head -> data);
            }
            putchar('
    ');
        }
    }
  • 相关阅读:
    Vs2017添加引用时报错未能正确加载“ReferenceManagerPackage”包。
    Java中数组复制的几种方法
    Java类的执行顺序
    JVM——代空间的划分
    JVM——垃圾收集器
    Java异常体系结构
    设计模式——单例模式
    Java多线程系列——原子类的实现(CAS算法)
    乐观锁与悲观锁
    Java中Volatile关键字详解
  • 原文地址:https://www.cnblogs.com/8023spz/p/8037313.html
Copyright © 2011-2022 走看看