zoukankan      html  css  js  c++  java
  • Color the ball

    N个气球排成一排,从左到右依次编号为1,2,3....N.每次给定2个整数a b(a <= b),lele便为骑上他的“小飞鸽"牌电动车从气球a开始到气球b依次给每个气球涂一次颜色。但是N次以后lele已经忘记了第I个气球已经涂过几次颜色了,你能帮他算出每个气球被涂过几次颜色吗?

    Input每个测试实例第一行为一个整数N,(N <= 100000).接下来的N行,每行包括2个整数a b(1 <= a <= b <= N)。
    当N = 0,输入结束。Output每个测试实例输出一行,包括N个整数,第I个数代表第I个气球总共被涂色的次数。Sample Input
    3
    1 1
    2 2
    3 3
    3
    1 1
    1 2
    1 3
    0
    Sample Output
    1 1 1
    3 2 1


    a到b区间的加1,只需要a加上1,b之后的再减1就好了。
    代码:
    #include <iostream>
    #include <cstdio>
    #include <cstring>
    using namespace std;
    int n,tree[100001];
    int lowbit(int t)
    {
        return t&-t;
    }
    void add(int x,int y)
    {
        while(x <= n)
        {
            tree[x] += y;
            x += lowbit(x);
        }
    }
    int getans(int x)
    {
        int ans = 0;
        while(x > 0)
        {
            ans += tree[x];
            x -= lowbit(x);
        }
        return ans;
    }
    int main ()
    {
        int a,b;
        while(~scanf("%d",&n) && n)
        {
            memset(tree,0,sizeof(tree));
            for(int i = 0;i < n;i ++)
            {
                scanf("%d%d",&a,&b);
                add(a,1);
                add(b+1,-1);
            }
            for(int i = 1;i <= n;i ++)
            {
                if(i > 1)
                {
                    printf(" %d",getans(i));
                }
                else
                {
                    printf("%d",getans(i));
                }
            }
            putchar('
    ');
        }
    }
  • 相关阅读:
    第一次个人编程作业
    第一次软工作业
    [Manacher]最长回文子串
    面向对象程序设计 总结作业
    面向对象程序设计 小黄衫晒单
    面向对象程序设计 作业三
    面向对象程序设计 作业二
    面向对象程序设计 作业一
    SSD/Memory技术学习拼图
    第一次结对编程作业
  • 原文地址:https://www.cnblogs.com/8023spz/p/8331103.html
Copyright © 2011-2022 走看看