zoukankan      html  css  js  c++  java
  • AtCoder Beginner Contest 087 B

    Time limit : 2sec / Memory limit : 256MB

    Score : 200 points

    Problem Statement

    You have A 500-yen coins, B 100-yen coins and C 50-yen coins (yen is the currency of Japan). In how many ways can we select some of these coins so that they are X yen in total?

    Coins of the same kind cannot be distinguished. Two ways to select coins are distinguished when, for some kind of coin, the numbers of that coin are different.

    Constraints

    • 0≤A,B,C≤50
    • A+B+C≥1
    • 50≤X≤20 000
    • A, B and C are integers.
    • X is a multiple of 50.

    Input

    Input is given from Standard Input in the following format:

    A
    B
    C
    X
    

    Output

    Print the number of ways to select coins.


    Sample Input 1

    Copy
    2
    2
    2
    100
    

    Sample Output 1

    Copy
    2
    

    There are two ways to satisfy the condition:

    • Select zero 500-yen coins, one 100-yen coin and zero 50-yen coins.
    • Select zero 500-yen coins, zero 100-yen coins and two 50-yen coins.

    Sample Input 2

    Copy
    5
    1
    0
    150
    

    Sample Output 2

    Copy
    0
    

    Note that the total must be exactly X yen.


    Sample Input 3

    Copy
    30
    40
    50
    6000
    

    Sample Output 3

    Copy
    213

    直接暴力枚举

    代码:
    #include <iostream>
    #include <algorithm>
    #include <cstdio>
    #include <cstdlib>
    #include <cstring>
    #include <cmath>
    #include <iomanip>
    using namespace std;
    int a,b,c,x,d;
     
    int main()
    {
        cin>>a>>b>>c>>x;
        for(int i = 0;i <= a;i ++)
        {
            for(int j = 0;j <= b;j ++)
            {
                for(int k = 0;k <= c;k ++)
                    if(i * 500 + j * 100 + k * 50 == x)d ++;
            }
        }
        cout<<d<<endl;
    }
  • 相关阅读:
    owlsuddimatchmaker安装
    类集
    jsp基本语法
    心得思路记录下
    nyoj517 最小公倍数
    poj1250 Tanning Salon
    poj1686 Lazy Math Instructor
    poj3250 Bad Hair Day
    poj1047 Round and Round We Go
    poj2359 Questions
  • 原文地址:https://www.cnblogs.com/8023spz/p/8409126.html
Copyright © 2011-2022 走看看