zoukankan      html  css  js  c++  java
  • 1147. Heaps (30)

    In computer science, a heap is a specialized tree-based data structure that satisfies the heap property: if P is a parent node of C, then the key (the value) of P is either greater than or equal to (in a max heap) or less than or equal to (in a min heap) the key of C. A common implementation of a heap is the binary heap, in which the tree is a complete binary tree. (Quoted from Wikipedia at https://en.wikipedia.org/wiki/Heap_(data_structure))

    Your job is to tell if a given complete binary tree is a heap.

    Input Specification:

    Each input file contains one test case. For each case, the first line gives two positive integers: M (<= 100), the number of trees to be tested; and N (1 < N <= 1000), the number of keys in each tree, respectively. Then M lines follow, each contains N distinct integer keys (all in the range of int), which gives the level order traversal sequence of a complete binary tree.

    Output Specification:

    For each given tree, print in a line "Max Heap" if it is a max heap, or "Min Heap" for a min heap, or "Not Heap" if it is not a heap at all. Then in the next line print the tree's postorder traversal sequence. All the numbers are separated by a space, and there must no extra space at the beginning or the end of the line.

    Sample Input:
    3 8
    98 72 86 60 65 12 23 50
    8 38 25 58 52 82 70 60
    10 28 15 12 34 9 8 56
    
    Sample Output:
    Max Heap
    50 60 65 72 12 23 86 98
    Min Heap
    60 58 52 38 82 70 25 8
    Not Heap
    56 12 34 28 9 8 15 10
    

    判断最堆只需要判断从头到尾是否是一致的双亲大于(小于)左右儿子。
    代码:
    #include <iostream>
    #include <cstring>
    #include <cstdio>
    #include <map>
    #define Max 1005
    using namespace std;
    int n,m,h[Max],flag;
    bool check(bool tag)
    {
        for(int i = 1;i * 2 <= n;i ++)
        {
            if(h[i] != h[i * 2] && h[i] > h[i * 2] == tag)return 0;
            if(i * 2 + 1 <= n && h[i] != h[i * 2 + 1] && h[i] > h[i * 2 + 1] == tag)return 0;
        }
        return 1;
    }
    void post_order(int t)
    {
        if(t * 2 <= n)post_order(t * 2);
        if(t * 2 + 1 <= n)post_order(t * 2 + 1);
        if(flag ++)printf(" %d",h[t]);
        else printf("%d",h[t]);
    }
    int main()
    {
        scanf("%d%d",&m,&n);
        while(m --)
        {
            for(int i = 1;i <= n;i ++)
            {
                scanf("%d",&h[i]);
            }
            if(check(false))puts("Max Heap");
            else if(check(true))puts("Min Heap");
            else puts("Not Heap");
            flag = 0;
            post_order(1);
            puts("");
        }
    }
  • 相关阅读:
    将软件做成服务,并开机自启
    ubuntu下sublime Text3配置C++编译环境
    StratifiedKFold与GridSearchCV版本前后使用方法
    o2o优惠券使用预测
    Meshgrid函数的基本用法(转载)
    Andrew Ng机器学习课程,第一周作业,python版本
    多元高斯分布(转载)
    Tensorflow图像处理
    TensorFlow最佳实践样例
    个人资源索引
  • 原文地址:https://www.cnblogs.com/8023spz/p/8933021.html
Copyright © 2011-2022 走看看