zoukankan      html  css  js  c++  java
  • poj 3616 Milking Time

    Description

    Bessie is such a hard-working cow. In fact, she is so focused on maximizing her productivity that she decides to schedule her next N (1 ≤ N ≤ 1,000,000) hours (conveniently labeled 0..N-1) so that she produces as much milk as possible.

    Farmer John has a list of M (1 ≤ M ≤ 1,000) possibly overlapping intervals in which he is available for milking. Each interval i has a starting hour (0 ≤ starting_houri ≤ N), an ending hour (starting_houri < ending_houri ≤ N), and a corresponding efficiency (1 ≤ efficiencyi ≤ 1,000,000) which indicates how many gallons of milk that he can get out of Bessie in that interval. Farmer John starts and stops milking at the beginning of the starting hour and ending hour, respectively. When being milked, Bessie must be milked through an entire interval.

    Even Bessie has her limitations, though. After being milked during any interval, she must rest R (1 ≤ R ≤ N) hours before she can start milking again. Given Farmer Johns list of intervals, determine the maximum amount of milk that Bessie can produce in the N hours.

    Input

    * Line 1: Three space-separated integers: NM, and R
    * Lines 2..M+1: Line i+1 describes FJ's ith milking interval withthree space-separated integers: starting_houri , ending_houri , and efficiencyi

    Output

    * Line 1: The maximum number of gallons of milk that Bessie can product in the N hours

    Sample Input

    12 4 2
    1 2 8
    10 12 19
    3 6 24
    7 10 31

    Sample Output

    43
    题意不难理解,给出一些时间区间,和区间内能完成的数量,每做完一个时间区间的都要等r小时,才能继续也就是说下一次开始与上一次结束的时间相差要不小于r,一开始是通过时间来更新超时了,时间很多呢,但是区间最多有1000个,所以通过区间来更新,O(m^2)的算法。、
    先按照结束时间排序,排着遍历更新,dp[i]记录第i区间的最大完成量。
    代码:
    #include <iostream>
    #include <cstdio>
    #include <cstring>
    #include <cmath>
    #include <cstdlib>
    #include <algorithm>
    #define MAX 1001
    #define inf 0x3f3f3f3f
    using namespace std;
    struct interval {
        int sh,eh,e;
    }in[1001];
    int n,m,r,dp[1001];
    bool cmp(interval a,interval b) {
        return a.eh < b.eh;
    }
    int main() {
        scanf("%d%d%d",&n,&m,&r);
        for(int i = 0;i < m;i ++) {
            scanf("%d%d%d",&in[i].sh,&in[i].eh,&in[i].e);
        }
        sort(in,in + m,cmp);///排序
        for(int i = 0;i < m;i ++) {
            dp[i] = in[i].e;
            for(int j = 0;j < i;j ++) {
                 if(in[j].eh + r <= in[i].sh)dp[i] = max(dp[i],dp[j] + in[i].e);///时间间隔满足r
                 else dp[i] = max(dp[i],dp[j]);
            }
        }
        printf("%d",dp[m - 1]);
    }
  • 相关阅读:
    ThinkPHP 3 的CURD管理用户信息 修改和删除
    检测一个字符串是否为一个有效的编码格式字符串
    将Buffer对象结合创建为一个新的Buffer对象
    Buffer.byteLength(字符串,编码方式)计算指定字符串的字节数
    TypeError: Buffer.allocUnsafe is not a function
    多个haproxy 之间跳转
    TypeError: Identifier 'assert' has already been declared
    14.5.7 Storing InnoDB Undo Logs in Separate Tablespaces 存储InnoDB Undo logs 到单独的表空间
    14.5.5 Creating a File-Per-Table Tablespace Outside the Data Directory
    php session 管理
  • 原文地址:https://www.cnblogs.com/8023spz/p/9529992.html
Copyright © 2011-2022 走看看