zoukankan      html  css  js  c++  java
  • PAT 1044. 火星数字

    PAT 1044. 火星数字

    火星人是以13进制计数的:

    地球人的0被火星人称为tret。
    地球人数字1到12的火星文分别为:jan, feb, mar, apr, may, jun, jly, aug, sep, oct, nov, dec。
    火星人将进位以后的12个高位数字分别称为:tam, hel, maa, huh, tou, kes, hei, elo, syy, lok, mer, jou。
    例如地球人的数字“29”翻译成火星文就是“hel mar”;而火星文“elo nov”对应地球数字“115”。为了方便交流,请你编写程序实现地球和火星数字之间的互译。

    输入格式:

    输入第一行给出一个正整数N(<100),随后N行,每行给出一个[0, 169)区间内的数字 —— 或者是地球文,或者是火星文。

    输出格式:

    对应输入的每一行,在一行中输出翻译后的另一种语言的数字。

    输入样例:

    4
    29
    5
    elo nov
    tam
    

    输出样例:

    hel mar
    may
    115
    13
    

    代码如下

    #include<iostream>
    #include<algorithm>
    #include<vector>
    #include<sstream>
    using namespace std;
    int main(){
    	vector<string> gewei{"tret","jan","feb","mar","apr","may","jun","jly","aug","sep","oct","nov","dec"};
    	vector<string> shiwei{"#","tam","hel","maa","huh","tou","kes","hei","elo","syy","lok","mer","jou"};
    	int N; cin>>N;
    	string s,str; int a,b,c;
    	getchar();
    	while(N--){
    		int sum=0;
    		getline(cin,s);
    		if(isdigit(s[0])){
    		c=stoi(s); // 将s转化为int
    		if(c<13) cout<<gewei[c]<<endl;
    		else{
    			if(c%13==0) cout<<shiwei[c/13]<<endl; // 13的倍数是不要输出tret的
    			else cout<<shiwei[c/13]<<" "<<gewei[c%13]<<endl;
    		}
    		}
    		else{
    			istringstream is(s); // 利用istringstream读取s中的单词
    			while(is>>str){
    				auto it=find(shiwei.begin(),shiwei.end(),str);
    				if(it!=shiwei.end())
    				sum+=(it-shiwei.begin())*13;
    				auto itt=find(gewei.begin(),gewei.end(),str);
    				if(itt!=gewei.end())
    				sum+=(itt-gewei.begin());
    			}
    			cout<<sum<<endl; 
    	}
    }
    	return 0;
    }
    
  • 相关阅读:
    爬虫-解析库-beautisoup
    爬虫-请求库-requests库
    爬虫-简单爬取视频
    爬虫基本原理
    虚拟环境搭建+前后端项目搭建
    flask-自定义命令、多APP应用、 wtforms、sqlalcchemy
    flask-蓝图
    flask- 偏函数、请求上下文、信号、flask-session保存redis中
    flash框架-安装、路由、配置、请求与响应
    svn服务器镜像备份
  • 原文地址:https://www.cnblogs.com/A-Little-Nut/p/8119851.html
Copyright © 2011-2022 走看看