zoukankan      html  css  js  c++  java
  • PAT 1035. Password

    To prepare for PAT, the judge sometimes has to generate random passwords for the users. The problem is that there are always some confusing passwords since it is hard to distinguish 1 (one) from l (L in lowercase), or 0 (zero) from O (o in uppercase). One solution is to replace 1 (one) by @, 0 (zero) by %, l by L, and O by o. Now it is your job to write a program to check the accounts generated by the judge, and to help the juge modify the confusing passwords.

    Input Specification:

    Each input file contains one test case. Each case contains a positive integer N (<= 1000), followed by N lines of accounts. Each account consists of a user name and a password, both are strings of no more than 10 characters with no space.

    Output Specification:

    For each test case, first print the number M of accounts that have been modified, then print in the following M lines the modified accounts info, that is, the user names and the corresponding modified passwords. The accounts must be printed in the same order as they are read in. If no account is modified, print in one line "There are N accounts and no account is modified" where N is the total number of accounts. However, if N is one, you must print "There is 1 account and no account is modified" instead.

    Sample Input 1:

    3
    Team000002 Rlsp0dfa
    Team000003 perfectpwd
    Team000001 R1spOdfa
    

    Sample Output 1:

    2
    Team000002 RLsp%dfa
    Team000001 R@spodfa
    

    Sample Input 2:

    1
    team110 abcdefg332
    

    Sample Output 2:

    There is 1 account and no account is modified
    

    Sample Input 3:

    2
    team110 abcdefg222
    team220 abcdefg333
    

    Sample Output 3:

    There are 2 accounts and no account is modified
    

    这道题没什么可说的是吧?

    #include<iostream>
    #include<map>
    #include<vector>
    using namespace std;
    struct student{
    	string name,password;
    };
    int main(){
    	int n,cnt=0;
    	cin>>n;
    	map<char,char> trans={{'1','@'},{'0','%'},{'l','L'},{'O','o'}};
    	vector<student> students;
    	for(int i=0;i<n;i++){
    		int flag=0;
    		student stud;
    		cin>>stud.name>>stud.password;
    		for(int j=0;j<stud.password.size();j++){
    			if(trans[stud.password[j]]!=''){
    				flag=1; cnt=0;
    				stud.password[j]=trans[stud.password[j]];
    			}
    		}
            if(flag==1) students.push_back(stud);
    	}
    	if(students.size()!=0){
    		cout<<students.size()<<endl;
    		for(auto o:students)
    		cout<<o.name<<" "<<o.password<<endl;
    	}else if(n==1)
    	    cout<<"There is 1 account and no account is modified"<<endl;
    	 else
    	    printf("There are %d accounts and no account is modified",n); 
    	return 0;
    }
    
  • 相关阅读:
    不容易系列之一(错排)
    找新朋友(欧拉函数)
    二分查找
    快速排序(分治)
    归并排序(分治)
    畅通工程(并查集)
    A Knight's Journey (DFS)
    Network Saboteur (DFS)
    Oil Deposits(油田)(DFS)
    Dungeon Master (三维BFS)
  • 原文地址:https://www.cnblogs.com/A-Little-Nut/p/8301148.html
Copyright © 2011-2022 走看看