zoukankan      html  css  js  c++  java
  • PAT 1048. Find Coins

    Eva loves to collect coins from all over the universe, including some other planets like Mars. One day she visited a universal shopping mall which could accept all kinds of coins as payments. However, there was a special requirement of the payment: for each bill, she could only use exactly two coins to pay the exact amount. Since she has as many as 105 coins with her, she definitely needs your help. You are supposed to tell her, for any given amount of money, whether or not she can find two coins to pay for it.

    Input Specification:

    Each input file contains one test case. For each case, the first line contains 2 positive numbers: N (<=105, the total number of coins) and M(<=103, the amount of money Eva has to pay). The second line contains N face values of the coins, which are all positive numbers no more than 500. All the numbers in a line are separated by a space.

    Output Specification:

    For each test case, print in one line the two face values V1 and V2 (separated by a space) such that V1 + V2 = M and V1 <= V2. If such a solution is not unique, output the one with the smallest V1. If there is no solution, output "No Solution" instead.

    Sample Input 1:

    8 15
    1 2 8 7 2 4 11 15
    

    Sample Output 1:

    4 11
    

    Sample Input 2:

    7 14
    1 8 7 2 4 11 15
    

    Sample Output 2:

    No Solution
    

    分析
    这题比较简单,应该属于散列吧

    #include<iostream>
    using namespace std;
    int face[501]={0};
    int main(){
    	int n,m,num;
    	cin>>n>>m;
    	for(int i=0;i<n;i++){
    		cin>>num;
    		face[num]++;
    	}
    	for(int i=1;i<=500;i++){
    		if(face[i]==0) continue;
    		face[i]--;
    		if(m-i>0&&m-i<=500&&face[m-i]>=1){
    		   cout<<i<<" "<<m-i<<endl;
    		   return 0;
    		}
    	}
    	cout<<"No Solution"<<endl;
    	return 0;
    }
    
  • 相关阅读:
    二分搜索树的深度优先遍历和广度优先遍历
    数据结构与算法之非比较排序【Java】
    数据结构与算法之比较排序【Java】
    像素 转换 px dp
    Toast
    MySQL丶auto_increment
    MariaDB · 性能优化 · Extended Keys
    加唯一索引怎么会导致丢数据
    语句执行错误一· Count(Distinct) ERROR
    innodb参数 &#183; innodb_flush_log_at_trx_commit
  • 原文地址:https://www.cnblogs.com/A-Little-Nut/p/8328332.html
Copyright © 2011-2022 走看看