zoukankan      html  css  js  c++  java
  • PAT 1079. Total Sales of Supply Chain

    A supply chain is a network of retailers(零售商), distributors(经销商), and suppliers(供应商)-- everyone involved in moving a product from supplier to customer.

    Starting from one root supplier, everyone on the chain buys products from one's supplier in a price P and sell or distribute them in a price that is r% higher than P. Only the retailers will face the customers. It is assumed that each member in the supply chain has exactly one supplier except the root supplier, and there is no supply cycle.

    Now given a supply chain, you are supposed to tell the total sales from all the retailers.

    Input Specification:

    Each input file contains one test case. For each case, the first line contains three positive numbers: N (<=105), the total number of the members in the supply chain (and hence their ID's are numbered from 0 to N-1, and the root supplier's ID is 0); P, the unit price given by the root supplier; and r, the percentage rate of price increment for each distributor or retailer. Then N lines follow, each describes a distributor or retailer in the following format:

    Ki ID[1] ID[2] ... ID[Ki]

    where in the i-th line, Ki is the total number of distributors or retailers who receive products from supplier i, and is then followed by the ID's of these distributors or retailers. Kj being 0 means that the j-th member is a retailer, then instead the total amount of the product will be given after Kj. All the numbers in a line are separated by a space.

    Output Specification:

    For each test case, print in one line the total sales we can expect from all the retailers, accurate up to 1 decimal place. It is guaranteed that the number will not exceed 1010.

    Sample Input:

    10 1.80 1.00
    3 2 3 5
    1 9
    1 4
    1 7
    0 7
    2 6 1
    1 8
    0 9
    0 4
    0 3

    Sample Output:

    42.4

    分析

    用邻接表法建图,用ret数组储存零售商的信息,用深度优先搜索法,从0开始搜索,知道遇到叶子节点(即是零售商),期间用level来储存层级,每一层表示原始价格乘以(1+r%).

    #include<iostream>
    #include<algorithm>
    #include<vector>
    #include<math.h>
    using namespace std;
    const int inf=9999999;
    vector<int> G[100001];
    int visited[100001]={0},ret[100001]={0},n,level=-1;
    double p,r,sale=0;
    void dfs(int root){
    	 level++;
    	 visited[root]=1;
    	 if(G[root].size()==0){
    	 	sale+=p*pow(1+0.01*r,level)*ret[root];
    	 	level--;
    	 	return ;
    	 }
    	 for(int i=0;i<G[root].size();i++)
    	     if(visited[G[root][i]]==0)
    	        dfs(G[root][i]);
         level--;
    }
    int main(){
    	cin>>n>>p>>r;
    	for(int i=0;i<n;i++){
    		int num,u;
    		cin>>num;
    		if(num!=0){
    			for(int j=0;j<num;j++){
    			   cin>>u;
    			   G[i].push_back(u);
    		    }
    		}else{
    			cin>>u;
    			ret[i]=u;
    		}   
    	}
    	dfs(0);
    	printf("%.1lf",sale);
    	return 0;
    }
    
  • 相关阅读:
    设计模式之笔记--工厂方法模式(Factory Method)
    dmesg命令
    jumpserver2.3.0社区开源版
    container偶尔宕掉问题的解决记录
    sshd服务的白名单和黑名单
    /proc/sysrq-trigger文件
    ansible定义主机清单
    简述Etcd、Lvs、HAProxy
    ES6语法 let、const、for...of循环、展开运算符、ES6箭头函数、箭头函数和this、模板字面量、解构、对象字面量简写法、默认参数函数、super 和 extends、Object.assign()
    axios 将post请求时把对象obj数据转为formdata
  • 原文地址:https://www.cnblogs.com/A-Little-Nut/p/8403673.html
Copyright © 2011-2022 走看看