zoukankan      html  css  js  c++  java
  • PAT 1079. Total Sales of Supply Chain

    A supply chain is a network of retailers(零售商), distributors(经销商), and suppliers(供应商)-- everyone involved in moving a product from supplier to customer.

    Starting from one root supplier, everyone on the chain buys products from one's supplier in a price P and sell or distribute them in a price that is r% higher than P. Only the retailers will face the customers. It is assumed that each member in the supply chain has exactly one supplier except the root supplier, and there is no supply cycle.

    Now given a supply chain, you are supposed to tell the total sales from all the retailers.

    Input Specification:

    Each input file contains one test case. For each case, the first line contains three positive numbers: N (<=105), the total number of the members in the supply chain (and hence their ID's are numbered from 0 to N-1, and the root supplier's ID is 0); P, the unit price given by the root supplier; and r, the percentage rate of price increment for each distributor or retailer. Then N lines follow, each describes a distributor or retailer in the following format:

    Ki ID[1] ID[2] ... ID[Ki]

    where in the i-th line, Ki is the total number of distributors or retailers who receive products from supplier i, and is then followed by the ID's of these distributors or retailers. Kj being 0 means that the j-th member is a retailer, then instead the total amount of the product will be given after Kj. All the numbers in a line are separated by a space.

    Output Specification:

    For each test case, print in one line the total sales we can expect from all the retailers, accurate up to 1 decimal place. It is guaranteed that the number will not exceed 1010.

    Sample Input:

    10 1.80 1.00
    3 2 3 5
    1 9
    1 4
    1 7
    0 7
    2 6 1
    1 8
    0 9
    0 4
    0 3

    Sample Output:

    42.4

    分析

    用邻接表法建图,用ret数组储存零售商的信息,用深度优先搜索法,从0开始搜索,知道遇到叶子节点(即是零售商),期间用level来储存层级,每一层表示原始价格乘以(1+r%).

    #include<iostream>
    #include<algorithm>
    #include<vector>
    #include<math.h>
    using namespace std;
    const int inf=9999999;
    vector<int> G[100001];
    int visited[100001]={0},ret[100001]={0},n,level=-1;
    double p,r,sale=0;
    void dfs(int root){
    	 level++;
    	 visited[root]=1;
    	 if(G[root].size()==0){
    	 	sale+=p*pow(1+0.01*r,level)*ret[root];
    	 	level--;
    	 	return ;
    	 }
    	 for(int i=0;i<G[root].size();i++)
    	     if(visited[G[root][i]]==0)
    	        dfs(G[root][i]);
         level--;
    }
    int main(){
    	cin>>n>>p>>r;
    	for(int i=0;i<n;i++){
    		int num,u;
    		cin>>num;
    		if(num!=0){
    			for(int j=0;j<num;j++){
    			   cin>>u;
    			   G[i].push_back(u);
    		    }
    		}else{
    			cin>>u;
    			ret[i]=u;
    		}   
    	}
    	dfs(0);
    	printf("%.1lf",sale);
    	return 0;
    }
    
  • 相关阅读:
    asp.net textbox控件readonly为true时,后台取值的问题
    未能加载文件或程序集“ICSharpCode.SharpZipLib, Version=0.86.0.518, Culture=neutral, PublicKeyToken=1b03e6acf1164f73”或它的某一个依赖项
    DataSet与DataReader的比较
    EntityFramwork所有 SSDL 项目都必须以同一提供程序为目标。ProviderManifestToken“2008”不同于以前遇到的“2005”
    路由器wan口连接不上的问题
    Git学习(四)----版本号跳转
    jquery记分牌的插件
    ORACLE 第4节 多表查询
    基于消息机制的异步架构之回调函数注冊
    干货!手把手教你怎样高速了解一个行业--游戏产业概况
  • 原文地址:https://www.cnblogs.com/A-Little-Nut/p/8403673.html
Copyright © 2011-2022 走看看