zoukankan      html  css  js  c++  java
  • PAT 1083. List Grades

    Given a list of N student records with name, ID and grade. You are supposed to sort the records with respect to the grade in non-increasing order, and output those student records of which the grades are in a given interval.

    Input Specification:

    Each input file contains one test case. Each case is given in the following format:

    N
    name[1] ID[1] grade[1]
    name[2] ID[2] grade[2]
    ... ...
    name[N] ID[N] grade[N]
    grade1 grade2

    where name[i] and ID[i] are strings of no more than 10 characters with no space, grade[i] is an integer in [0, 100], grade1 and grade2 are the boundaries of the grade's interval. It is guaranteed that all the grades are distinct.

    Output Specification:

    For each test case you should output the student records of which the grades are in the given interval [grade1, grade2] and are in non-increasing order. Each student record occupies a line with the student's name and ID, separated by one space. If there is no student's grade in that interval, output "NONE" instead.

    Sample Input 1:

    4
    Tom CS000001 59
    Joe Math990112 89
    Mike CS991301 100
    Mary EE990830 95
    60 100

    Sample Output 1:

    Mike CS991301
    Mary EE990830
    Joe Math990112

    Sample Input 2:

    2
    Jean AA980920 60
    Ann CS01 80
    90 95

    Sample Output 2:

    NONE

    #include<iostream>
    #include<vector>
    #include<algorithm>
    using namespace std;
    struct student{
    	int grade;
    	string name,id;
    };
    bool cmp(const student& s1,const student& s2){
    	return s1.grade>s2.grade;
    }
    int main(){
    	int n,lowest,highest,flag=0;
    	cin>>n;
    	vector<student> studs(n);
    	for(int i=0;i<n;i++)
    	    cin>>studs[i].name>>studs[i].id>>studs[i].grade;
    	cin>>lowest>>highest;
    	sort(studs.begin(),studs.end(),cmp);
    	for(int i=0;i<studs.size();i++){
    		if(studs[i].grade>=lowest&&studs[i].grade<=highest){
    			flag=1;
    			cout<<studs[i].name<<" "<<studs[i].id<<endl;
    		} 
    	}
    	if(flag==0) cout<<"NONE"<<endl;
    	return 0; 
    } 
    
  • 相关阅读:
    大数据测试2
    大数据测试3
    CROSS APPLY和 OUTER APPLY 区别详解
    SQL中的escape的用法
    Sql Server参数化查询之where in和like实现详解
    多行文本框换行符处理
    Cross Apply的用法
    交叉连接Cross Join的用法
    统计字符串中某个字符的个数
    JOIN用法
  • 原文地址:https://www.cnblogs.com/A-Little-Nut/p/8409575.html
Copyright © 2011-2022 走看看