zoukankan      html  css  js  c++  java
  • PAT 1122 Hamiltonian Cycle

    The "Hamilton cycle problem" is to find a simple cycle that contains every vertex in a graph. Such a cycle is called a "Hamiltonian cycle".

    In this problem, you are supposed to tell if a given cycle is a Hamiltonian cycle.

    Input Specification:
    Each input file contains one test case. For each case, the first line contains 2 positive integers N (2<N≤200), the number of vertices, and M, the number of edges in an undirected graph. Then M lines follow, each describes an edge in the format Vertex1 Vertex2, where the vertices are numbered from 1 to N. The next line gives a positive integer K which is the number of queries, followed by K lines of queries, each in the format:

    n V​1 V2​ ... Vn
    ​​

    where n is the number of vertices in the list, and Vi's are the vertices on a path.

    Output Specification:
    For each query, print in a line YES if the path does form a Hamiltonian cycle, or NO if not.

    Sample Input:
    6 10
    6 2
    3 4
    1 5
    2 5
    3 1
    4 1
    1 6
    6 3
    1 2
    4 5
    6
    7 5 1 4 3 6 2 5
    6 5 1 4 3 6 2
    9 6 2 1 6 3 4 5 2 6
    4 1 2 5 1
    7 6 1 3 4 5 2 6
    7 6 1 2 5 4 3 1

    Sample Output:
    YES
    NO
    NO
    NO
    YES
    NO

    #include<iostream> //水题
    #include<vector>
    using namespace std;
    int main(){
      int vn, en, qn;
      cin>>vn>>en;
      vector<vector<int>> map(vn+1, vector<int>(vn+1, 0));
      vector<int> visited(vn+1, 0);
      for(int i=0; i<en; i++){
        int v1, v2;
        cin>>v1>>v2;
        map[v1][v2]=map[v2][v1]=1;
      }
      cin>>qn;
      for(int i=0; i<qn; i++){
        int n, flag=0;
        cin>>n;
        vector<int> path(n, 0);
        vector<vector<int>> temp=map;
        vector<int> visited(vn+1, 0);
        for(int j=0; j<n; j++)
          cin>>path[j];
        if(path[0]!=path[n-1]){
          cout<<"NO"<<endl;
          continue;
        }
        for(int j=0; j<n-1; j++)
          if(temp[path[j]][path[j+1]]==1){
            visited[path[j]]=visited[path[j+1]]=1;
            temp[path[j]][path[j+1]]=temp[path[j+1]][path[j]]=0;
          }else{
          	flag=1;
          	break;
    	  }
        for(int j=1; j<=vn; j++)
          if(visited[j]!=1)
          	flag=1;
        flag==0?cout<<"YES"<<endl:cout<<"NO"<<endl;
      }
      return 0;
    }
    
  • 相关阅读:
    云计算设计模式(十一)——健康端点监控模式
    大数据R语言简析
    git查看/修改 用户名和邮箱
    MySQL查询和修改auto_increment的方法
    git 配置用户名和邮箱
    discuz安装小云app
    二维码转化为链接
    discuz更换域名,登录不了解决
    数据结构很重要
    C++ vector错误(1)
  • 原文地址:https://www.cnblogs.com/A-Little-Nut/p/9506431.html
Copyright © 2011-2022 走看看