zoukankan      html  css  js  c++  java
  • PAT 1126 Eulerian Path

    In graph theory, an Eulerian path is a path in a graph which visits every edge exactly once. Similarly, an Eulerian circuit is an Eulerian path which starts and ends on the same vertex. They were first discussed by Leonhard Euler while solving the famous Seven Bridges of Konigsberg problem in 1736. It has been proven that connected graphs with all vertices of even degree have an Eulerian circuit, and such graphs are called Eulerian. If there are exactly two vertices of odd degree, all Eulerian paths start at one of them and end at the other. A graph that has an Eulerian path but not an Eulerian circuit is called semi-Eulerian. (Cited from https://en.wikipedia.org/wiki/Eulerian_path)

    Given an undirected graph, you are supposed to tell if it is Eulerian, semi-Eulerian, or non-Eulerian.

    Input Specification:

    Each input file contains one test case. Each case starts with a line containing 2 numbers N (≤ 500), and M, which are the total number of vertices, and the number of edges, respectively. Then M lines follow, each describes an edge by giving the two ends of the edge (the vertices are numbered from 1 to N).

    Output Specification:

    For each test case, first print in a line the degrees of the vertices in ascending order of their indices. Then in the next line print your conclusion about the graph -- either Eulerian, Semi-Eulerian, or Non-Eulerian. Note that all the numbers in the first line must be separated by exactly 1 space, and there must be no extra space at the beginning or the end of the line.

    Sample Input 1:

    7 12
    5 7
    1 2
    1 3
    2 3
    2 4
    3 4
    5 2
    7 6
    6 3
    4 5
    6 4
    5 6

    Sample Output 1:

    2 4 4 4 4 4 2
    Eulerian

    Sample Input 2:

    6 10
    1 2
    1 3
    2 3
    2 4
    3 4
    5 2
    6 3
    4 5
    6 4
    5 6

    Sample Output 2:

    2 4 4 4 3 3
    Semi-Eulerian

    Sample Input 3:

    5 8
    1 2
    2 5
    5 4
    4 1
    1 3
    3 2
    3 4
    5 3

    Sample Output 3:

    3 3 4 3 3
    Non-Eulerian

    #include<iostream> //注意检查连通性
    #include<vector>
    using namespace std;
    int cnt=0;
    vector<vector<int>> graph;
    vector<int> visited(501, 0);
    void dfs(int s){
    	visited[s]=1;
    	cnt++;
    	for(int i=0; i<graph[s].size(); i++)
    		if(visited[graph[s][i]]==0)
    			dfs(graph[s][i]);
    }
    int main(){
      int vn, en, even=0;
      cin>>vn>>en;
      vector<int> degrees(vn+1, 0);
      graph.resize(vn+1);
      for(int i=0; i<en; i++){
        int v1, v2;
        cin>>v1>>v2; 
        graph[v1].push_back(v2);
        graph[v2].push_back(v1);
        degrees[v1]++;
        degrees[v2]++;
      }
      dfs(1);
      for(int i=1; i<=vn; i++){
      	i==1?cout<<degrees[i]:cout<<" "<<degrees[i];
      	even=(degrees[i]%2==0?even:even+1);
      }    
      cout<<endl;
      if(even==0&&cnt==vn)
        cout<<"Eulerian"<<endl;
      else if(even==2&&cnt==vn)
        cout<<"Semi-Eulerian"<<endl;
      else
        cout<<"Non-Eulerian"<<endl;
      return 0;
    }
    
  • 相关阅读:
    欢迎加入本人建的QQ群,讨论技术,生活及每天都有招聘信息
    ThreadPool(线程池) in .Net
    Android和Unity混合开发——解决方案
    HoloLens的显示分辨率有多少?
    ARGB_8888
    这几天用高通VUFORIA的体会
    利用WMI检测电脑硬件信息,没办法显示cpu的信息
    高版本teamview的成为被控制端时,会一直出现“正在初始化显示参数”
    Windows Server 2012 R2搭建IIS服务器
    如何设置Win7不待机 Win7进入待机状态会断网的解决方法
  • 原文地址:https://www.cnblogs.com/A-Little-Nut/p/9506562.html
Copyright © 2011-2022 走看看