zoukankan      html  css  js  c++  java
  • PAT 1137 Final Grading

    For a student taking the online course "Data Structures" on China University MOOC (http://www.icourse163.org/), to be qualified for a certificate, he/she must first obtain no less than 200 points from the online programming assignments, and then receive a final grade no less than 60 out of 100. The final grade is calculated by G=(G​mid−term×40%+Gfinal×60%) if Gmid−term>G​final, or Gfinal will be taken as the final grade G. Here Gmid−term and Gfinal are the student's scores of the mid-term and the final exams, respectively.

    The problem is that different exams have different grading sheets. Your job is to write a program to merge all the grading sheets into one.

    Input Specification:
    Each input file contains one test case. For each case, the first line gives three positive integers: P , the number of students having done the online programming assignments; M, the number of students on the mid-term list; and N, the number of students on the final exam list. All the numbers are no more than 10,000.

    Then three blocks follow. The first block contains P online programming scores Gp 's; the second one contains M mid-term scores Gmid−term's; and the last one contains N final exam scores Gfinal 's. Each score occupies a line with the format: StudentID Score, where StudentID is a string of no more than 20 English letters and digits, and Score is a nonnegative integer (the maximum score of the online programming is 900, and that of the mid-term and final exams is 100).

    ***Output Specification:
    For each case, print the list of students who are qualified for certificates. Each student occupies a line with the format:

    StudentID G​p Gmid−term Gfinal G

    If some score does not exist, output "−1" instead. The output must be sorted in descending order of their final grades (G must be rounded up to an integer). If there is a tie, output in ascending order of their StudentID's. It is guaranteed that the StudentID's are all distinct, and there is at least one qullified student.

    Sample Input:

    6 6 7
    01234 880
    a1903 199
    ydjh2 200
    wehu8 300
    dx86w 220
    missing 400
    ydhfu77 99
    wehu8 55
    ydjh2 98
    dx86w 88
    a1903 86
    01234 39
    ydhfu77 88
    a1903 66
    01234 58
    wehu8 84
    ydjh2 82
    missing 99
    dx86w 81

    Sample Output:

    missing 400 -1 99 99
    ydjh2 200 98 82 88
    dx86w 220 88 81 84
    wehu8 300 55 84 84

    #include<iostream> //海星
    #include<map>
    #include<algorithm>
    #include<vector> 
    #include<math.h>
    using namespace std;
    struct node{
    	string name;
    	int Gp, Gm, Gf, G;
    };
    bool cmp(node n1, node n2){
    	return (n1.G==n2.G?n1.name<n2.name:n1.G>n2.G);
    }
    int main(){
    	map<string, int> index;
    	vector<node> rank;
    	string id;
    	int p, m, n, cnt=1, s;
    	cin>>p>>m>>n;
    	for(int i=0; i<p; i++){
    		cin>>id>>s;
    		if(s>=200){
    			rank.push_back(node{id, s, -1, -1});
    			index[id]=cnt++; 
    		}
    	}
    	for(int i=0; i<m; i++){
    		cin>>id>>s;
    		if(index[id]!=0)
    			rank[index[id]-1].Gm=s;
    	}
    	for(int i=0; i<n; i++){
    		cin>>id>>s;
    		if(index[id]!=0){
    			rank[index[id]-1].Gf=s;
    			if(s>=rank[index[id]-1].Gm)
    				rank[index[id]-1].G=s;
    			else
    				rank[index[id]-1].G=round(0.4*rank[index[id]-1].Gm+0.6*s); 
    		}
    	}
    	sort(rank.begin(), rank.end(), cmp);
    	for(int i=0; i<rank.size(); i++)
    		if(rank[i].G>=60)
    			cout<<rank[i].name<<" "<<rank[i].Gp<<" "<<rank[i].Gm<<" "<<rank[i].Gf<<" "<<rank[i].G<<endl;
    	return 0; 
    } 
    
  • 相关阅读:
    sprintf与snprintf
    风雨20年:我所积累的20条编程经验
    istream_iterator, ostream_iterator,copy以及文件序列化
    [转载]关于C++,我觉得好的设计法则
    如何高效地管理时间
    B站上适合程序员的学习资源【赶紧收藏!】
    Redis和Memcached的区别
    Swoole的多进程模块
    Mac OS 查看 ip 地址及 DHCP 各 addr 含义
    mac将phpstorm 从主屏移动到副显示器(解决)
  • 原文地址:https://www.cnblogs.com/A-Little-Nut/p/9651966.html
Copyright © 2011-2022 走看看