zoukankan      html  css  js  c++  java
  • PAT 1142 Maximal Clique

    A clique is a subset of vertices of an undirected graph such that every two distinct vertices in the clique are adjacent. A maximal clique is a clique that cannot be extended by including one more adjacent vertex. (Quoted from https://en.wikipedia.org/wiki/Clique_(graph_theory))

    Now it is your job to judge if a given subset of vertices can form a maximal clique.

    Input Specification:
    Each input file contains one test case. For each case, the first line gives two positive integers Nv (≤ 200), the number of vertices in the graph, and Ne, the number of undirected edges. Then Ne lines follow, each gives a pair of vertices of an edge. The vertices are numbered from 1 to Nv.

    After the graph, there is another positive integer M (≤ 100). Then M lines of query follow, each first gives a positive number K (≤ Nv), then followed by a sequence of K distinct vertices. All the numbers in a line are separated by a space.

    Output Specification:
    For each of the M queries, print in a line Yes if the given subset of vertices can form a maximal clique; or if it is a clique but not a maximal clique, print Not Maximal; or if it is not a clique at all, print Not a Clique.

    Sample Input:

    8 10
    5 6
    7 8
    6 4
    3 6
    4 5
    2 3
    8 2
    2 7
    5 3
    3 4
    6
    4 5 4 3 6
    3 2 8 7
    2 2 3
    1 1
    3 4 3 6
    3 3 2 1

    Sample Output:

    Yes
    Yes
    Yes
    Yes
    Not Maximal
    Not a Clique

    #include<iostream>
    #include<vector>
    using namespace std;
    int main(){
    	int nv, ne, k, n;
    	cin>>nv>>ne;
    	vector<vector<int>> G(205, vector<int>(205, 0));
    	for(int i=0; i<ne; i++){
    		int v1, v2;
    		cin>>v1>>v2;
    		G[v1][v2]=G[v2][v1]=1;
    	} 
    	cin>>k;
    	for(int i=0; i<k; i++){
    		bool full=true, clique=true;
    		cin>>n;
    		vector<int> vi(n, 0), a(nv+1, 0);
    		for(int j=0; j<n; j++){
    			cin>>vi[j];
    			a[vi[j]]=1;
    		}
    		for(int j=0; j<n; j++){
    			if(clique==false) break;
    			for(int l=j+1; l<n; l++){
    				if(G[vi[j]][vi[l]]!=1){
    					clique=false;
    					cout<<"Not a Clique"<<endl;
    					break;
    				}		
    			}	
    		}
    		if(clique==false) continue;
    		for(int j=1; j<=200; j++){
    			if(a[j]==0){
    				for(int l=0; l<n; l++){
    					if(G[vi[l]][j]==0)	break;
    					if(l==n-1) full=false;
    				}
    			}
    			if(!full){
    				cout<<"Not Maximal"<<endl;
    				break;
    			}	
    		}	
    			if(full) cout<<"Yes"<<endl;	
    	}
    	return 0;
    } 
    
  • 相关阅读:
    Microsoft 基准安全分析器(MBSA)
    神奇的C++模版
    Windows下的Memcache安装
    BisonFlex 笔记
    虚函数背后的秘密
    如何切换SecureCRT的帐号
    动态生成JS 实现 .NET 网站广告管理
    fatal error C1853 预编译头文件来自编译器的早期版本 解决方法
    解决 unresolved external symbol 无法解析 _send@16
    linux远程登录
  • 原文地址:https://www.cnblogs.com/A-Little-Nut/p/9652266.html
Copyright © 2011-2022 走看看