zoukankan      html  css  js  c++  java
  • 【hdu 1517】A Multiplication Game

    Time Limit: 5000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 5536 Accepted Submission(s): 3151

    Problem Description
    Stan and Ollie play the game of multiplication by multiplying an integer p by one of the numbers 2 to 9. Stan always starts with p = 1, does his multiplication, then Ollie multiplies the number, then Stan and so on. Before a game starts, they draw an integer 1 < n < 4294967295 and the winner is who first reaches p >= n.

    Input
    Each line of input contains one integer number n.

    Output
    For each line of input output one line either

    Stan wins.

    or

    Ollie wins.

    assuming that both of them play perfectly.

    Sample Input
    162
    17
    34012226

    Sample Output
    Stan wins.
    Ollie wins.
    Stan wins.

    【题目链接】:http://acm.hdu.edu.cn/showproblem.php?pid=1517

    【题解】

    用sg函数容易推出来小数据的答案;
    如下”()”表示先手赢而”{}”表示先手输
    这里写图片描述
    一开始l = 2,r = 9;
    递推的话
    l = r+1;
    如果这次是先手赢
    则接下来是先手输的态
    r = r*2;
    如果这次是先手输
    则接下来是先手赢的态
    r = r*9;
    (感性理解:让先手输比较难)

    【完整代码】

    #include <bits/stdc++.h>
    using namespace std;
    #define lson l,m,rt<<1
    #define rson m+1,r,rt<<1|1
    #define LL long long
    #define rep1(i,a,b) for (int i = a;i <= b;i++)
    #define rep2(i,a,b) for (int i = a;i >= b;i--)
    #define mp make_pair
    #define pb push_back
    #define fi first
    #define se second
    #define rei(x) scanf("%d",&x)
    #define rel(x) scanf("%I64d",&x)
    
    typedef pair<int,int> pii;
    typedef pair<LL,LL> pll;
    
    //const int MAXN = x;
    const int dx[9] = {0,1,-1,0,0,-1,-1,1,1};
    const int dy[9] = {0,0,0,-1,1,-1,1,-1,1};
    const double pi = acos(-1.0);
    
    LL n;
    
    int main()
    {
        //freopen("F:\rush.txt","r",stdin);
        while (~scanf("%I64d",&n))
        {
            int now = 1;
            LL l = 2,r = 9;
            while (true)
            {
                if (l<=n && n <= r)
                    break;
                l = r+1;
                if (now==1)
                    r = r*2;
                else
                    r = r*9;
                now ^= 1;
            }
            if (now)
                puts("Stan wins.");
            else
                puts("Ollie wins.");
        }
        return 0;
    }
    
  • 相关阅读:
    (Linux)CentOS7下安装JDK 1.8
    centos 7 防火墙操作
    centos 7 挂载U盘
    Linux(CentOs 7)系统重装笔记(二)---完全删除用户账号和root用户登录
    更改oracle数据库密码(因为密码过期)
    Linux(CentOs 7)系统重装笔记(一)
    C#中的double类型数据向SQL sqerver 存储与读取问题
    SQL Server (MSSQLSERVER) 服务由于下列服务特定错误而终止: %%17051
    django+uwsgi+nginx
    golang的array/slice
  • 原文地址:https://www.cnblogs.com/AWCXV/p/7626738.html
Copyright © 2011-2022 走看看