zoukankan      html  css  js  c++  java
  • 【hdu 1517】A Multiplication Game

    Time Limit: 5000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 5536 Accepted Submission(s): 3151

    Problem Description
    Stan and Ollie play the game of multiplication by multiplying an integer p by one of the numbers 2 to 9. Stan always starts with p = 1, does his multiplication, then Ollie multiplies the number, then Stan and so on. Before a game starts, they draw an integer 1 < n < 4294967295 and the winner is who first reaches p >= n.

    Input
    Each line of input contains one integer number n.

    Output
    For each line of input output one line either

    Stan wins.

    or

    Ollie wins.

    assuming that both of them play perfectly.

    Sample Input
    162
    17
    34012226

    Sample Output
    Stan wins.
    Ollie wins.
    Stan wins.

    【题目链接】:http://acm.hdu.edu.cn/showproblem.php?pid=1517

    【题解】

    用sg函数容易推出来小数据的答案;
    如下”()”表示先手赢而”{}”表示先手输
    这里写图片描述
    一开始l = 2,r = 9;
    递推的话
    l = r+1;
    如果这次是先手赢
    则接下来是先手输的态
    r = r*2;
    如果这次是先手输
    则接下来是先手赢的态
    r = r*9;
    (感性理解:让先手输比较难)

    【完整代码】

    #include <bits/stdc++.h>
    using namespace std;
    #define lson l,m,rt<<1
    #define rson m+1,r,rt<<1|1
    #define LL long long
    #define rep1(i,a,b) for (int i = a;i <= b;i++)
    #define rep2(i,a,b) for (int i = a;i >= b;i--)
    #define mp make_pair
    #define pb push_back
    #define fi first
    #define se second
    #define rei(x) scanf("%d",&x)
    #define rel(x) scanf("%I64d",&x)
    
    typedef pair<int,int> pii;
    typedef pair<LL,LL> pll;
    
    //const int MAXN = x;
    const int dx[9] = {0,1,-1,0,0,-1,-1,1,1};
    const int dy[9] = {0,0,0,-1,1,-1,1,-1,1};
    const double pi = acos(-1.0);
    
    LL n;
    
    int main()
    {
        //freopen("F:\rush.txt","r",stdin);
        while (~scanf("%I64d",&n))
        {
            int now = 1;
            LL l = 2,r = 9;
            while (true)
            {
                if (l<=n && n <= r)
                    break;
                l = r+1;
                if (now==1)
                    r = r*2;
                else
                    r = r*9;
                now ^= 1;
            }
            if (now)
                puts("Stan wins.");
            else
                puts("Ollie wins.");
        }
        return 0;
    }
    
  • 相关阅读:
    【MM系列】SAP库龄报表逻辑理解
    【MM系列】SAP技巧之更改布局
    【MM系列】SAP里批量设置采购信息记录删除标记
    《跃迁-从技术到管理的硅谷路径》读书笔记
    Java安全编码标准
    web安全/渗透测试--1--web安全原则
    使用spring validation完成数据后端校验
    9 个Java 异常处理的规则
    程序员必看:给你一份详细的Spring Boot知识清单
    Java架构技术知识点梳理
  • 原文地址:https://www.cnblogs.com/AWCXV/p/7626738.html
Copyright © 2011-2022 走看看