zoukankan      html  css  js  c++  java
  • PAT Advanced Level 1079

    1079 Total Sales of Supply Chain (25)(25 分)

    A supply chain is a network of retailers(零售商), distributors(经销商), and suppliers(供应商)-- everyone involved in moving a product from supplier to customer.

    Starting from one root supplier, everyone on the chain buys products from one's supplier in a price P and sell or distribute them in a price that is r% higher than P. Only the retailers will face the customers. It is assumed that each member in the supply chain has exactly one supplier except the root supplier, and there is no supply cycle.

    Now given a supply chain, you are supposed to tell the total sales from all the retailers.

    Input Specification:

    Each input file contains one test case. For each case, the first line contains three positive numbers: N (<=10^5^), the total number of the members in the supply chain (and hence their ID's are numbered from 0 to N-1, and the root supplier's ID is 0); P, the unit price given by the root supplier; and r, the percentage rate of price increment for each distributor or retailer. Then N lines follow, each describes a distributor or retailer in the following format:

    K~i~ ID[1] ID[2] ... ID[K~i~]

    where in the i-th line, K~i~ is the total number of distributors or retailers who receive products from supplier i, and is then followed by the ID's of these distributors or retailers. K~j~ being 0 means that the j-th member is a retailer, then instead the total amount of the product will be given after K~j~. All the numbers in a line are separated by a space.

    Output Specification:

    For each test case, print in one line the total sales we can expect from all the retailers, accurate up to 1 decimal place. It is guaranteed that the number will not exceed 10^10^.

    Sample Input:

    10 1.80 1.00
    3 2 3 5
    1 9
    1 4
    1 7
    0 7
    2 6 1
    1 8
    0 9
    0 4
    0 3

    Sample Output:

    42.4
    /**********************
    author: yomi
    date: 18.8.18
    ps:简单dfs一下
    **********************/
    #include <iostream>
    #include <vector>
    #include <cstdio>
    using namespace std;
    
    const int maxn = 100010;
    struct Node
    {
        vector<int>child;
        int id;
        double data;
    }node[maxn];
    double sum = 0.0;
    double p, r, price;
    bool vis[maxn];
    void dfs(int index)
    {
        int cnt = node[index].child.size();
        if(cnt == 0){
            sum += p*node[index].data;
            return;
        }
        if(!vis[index]){
            p = p*(r/100+1);
            vis[index] = true;
            for(int i=0; i<cnt; i++){
                dfs(node[node[index].child[i]].id);
            }
            p/=(r/100+1);
        }
    
    }
    int main()
    {
        int n, t, d;
        scanf("%d%lf%lf", &n, &p, &r);
        for(int i=0; i<n; i++){
            scanf("%d", &t);
            node[i].id = i;
            if(t>0){
                for(int j=0; j<t; j++){
                    scanf("%d", &d);
                    node[i].child.push_back(d);
                }
            }
            else if(t == 0){
                scanf("%lf", &node[i].data);
            }
    
        }
        price = p;
        dfs(0);
        printf("%.1f", sum);
        return 0;
    }
    /**
    Sample Input:
    10 1.80 1.00
    3 2 3 5
    1 9
    1 4
    1 7
    0 7
    2 6 1
    1 8
    0 9
    0 4
    0 3
    Sample Output:
    42.4
    **/
  • 相关阅读:
    【译】SQL Server误区30日谈Day3即时文件初始化特性可以在SQL Server中开启和关闭
    有关TSQL的10个好习惯
    【译】SQL Server误区30日谈Day6有关NULL位图的三个误区
    一次由重复索引导致的问题
    【译】SQL Server误区30日谈Day2DBCC CHECKDB会导致阻塞
    【译】SQL Server误区30日谈Day1正在运行的事务在服务器故障转移后继续执行
    CodeFileBaseClass 属性
    Mako 模板系统文档翻译(2) 语法
    终于搞定了 django 的 ajax 方式上传图片
    ASP.NET Ajax 调试技巧:用 FireBug 调试 UpdatePanel 不更新问题
  • 原文地址:https://www.cnblogs.com/AbsolutelyPerfect/p/9497968.html
Copyright © 2011-2022 走看看