zoukankan      html  css  js  c++  java
  • A

    The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid. 

    InputThe input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket. 
    OutputFor each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets. 
    Sample Input

    1 1
    *
    3 5
    *@*@*
    **@**
    *@*@*
    1 8
    @@****@*
    5 5 
    ****@
    *@@*@
    *@**@
    @@@*@
    @@**@
    0 0 

    Sample Output

    0
    1
    2
    2
    思路 : 这是一道特别经典的DFS题目 就是先找到一个@然后将与@相连的@全部变成“×” dfs结束,说明没有与@相连的点了 计一此数
    #include<iostream>
    #include<cstring>
    #include<cstdio>
    using namespace std;
    int n,m;
    char arr[150][150];
    int mark[150][150]={0};
    int d[8][2]={{1,0},{0,1},{0,-1},{-1,0},{1,1},{1,-1},{-1,1},{-1,-1}};
    void dfs(int x,int y){
        mark[x][y]=1;
        for(int i=0;i<8;i++){
            int dx=x+d[i][0];
            int dy=y+d[i][1];
            if(dx>=0&&dy>=0&&dx<n&&dy<m&&mark[dx][dy]==0&&arr[dx][dy]=='@'){
                arr[dx][dy]='*';
                dfs(dx,dy);
            }
        }
    }
    int main()
    {
        while(cin>>n>>m&&m){
            int ans=0;
            memset(mark,0,sizeof(mark));
            for(int i=0;i<n;i++)
                scanf("%s",&arr[i]);
            for(int i=0;i<n;i++)
                for(int j=0;j<m;j++)
                {
                    if(arr[i][j]=='@')
                    {
                        dfs(i,j);
                        ans++;
                    }
                }
                cout<<ans<<endl;
        }
        
        return 0;
    }
  • 相关阅读:
    转载:【Oracle 集群】RAC知识图文详细教程(三)--RAC工作原理和相关组件
    转载:【Oracle 集群】RAC知识图文详细教程(一)--集群概念介绍
    转载:【Oracle 集群】RAC知识图文详细教程(二)--Oracle 集群概念及原理
    题目总结
    面试题(包含答案)
    ElementUI动态表格数据转换formatter
    父组件搜索列表 给 子组件传值问题
    项目提取公共接口方法
    数组常用方法总结
    vue全局注册
  • 原文地址:https://www.cnblogs.com/Accepting/p/11237552.html
Copyright © 2011-2022 走看看