zoukankan      html  css  js  c++  java
  • C

    The island nation of Flatopia is perfectly flat. Unfortunately, Flatopia has a very poor system of public highways. The Flatopian government is aware of this problem and has already constructed a number of highways connecting some of the most important towns. However, there are still some towns that you can't reach via a highway. It is necessary to build more highways so that it will be possible to drive between any pair of towns without leaving the highway system. 

    Flatopian towns are numbered from 1 to N and town i has a position given by the Cartesian coordinates (xi, yi). Each highway connects exaclty two towns. All highways (both the original ones and the ones that are to be built) follow straight lines, and thus their length is equal to Cartesian distance between towns. All highways can be used in both directions. Highways can freely cross each other, but a driver can only switch between highways at a town that is located at the end of both highways. 

    The Flatopian government wants to minimize the cost of building new highways. However, they want to guarantee that every town is highway-reachable from every other town. Since Flatopia is so flat, the cost of a highway is always proportional to its length. Thus, the least expensive highway system will be the one that minimizes the total highways length. 

    Input

    The input consists of two parts. The first part describes all towns in the country, and the second part describes all of the highways that have already been built. 

    The first line of the input file contains a single integer N (1 <= N <= 750), representing the number of towns. The next N lines each contain two integers, xi and yi separated by a space. These values give the coordinates of i th town (for i from 1 to N). Coordinates will have an absolute value no greater than 10000. Every town has a unique location. 

    The next line contains a single integer M (0 <= M <= 1000), representing the number of existing highways. The next M lines each contain a pair of integers separated by a space. These two integers give a pair of town numbers which are already connected by a highway. Each pair of towns is connected by at most one highway. 

    Output

    Write to the output a single line for each new highway that should be built in order to connect all towns with minimal possible total length of new highways. Each highway should be presented by printing town numbers that this highway connects, separated by a space. 

    If no new highways need to be built (all towns are already connected), then the output file should be created but it should be empty. 

    Sample Input

    9
    1 5
    0 0 
    3 2
    4 5
    5 1
    0 4
    5 2
    1 2
    5 3
    3
    1 3
    9 7
    1 2

    Sample Output

    1 6
    3 7
    4 9
    5 7
    8 3
    第一次接触不给权值的最小生成树问题,处理方法和原来一样。。
    题目大意:首先输入有N个城市,然后按照城市顺序输入城市的坐标。最后输出的是需要在哪两个城市之间添加一下路径,这个题目还有个坑就是,输出的结果,对顺序没有要求。
    就是即便把1 3 输出成了3 1 也无所谓的

    #include<iostream>
    #include<algorithm>
    #include<cstdio>
    using namespace std;
    const int N= 1E6+10;
    int pre[N];
    struct stu{
        int a,b;
        int x;
    }p[N],pp[N];
    
    bool cmp(stu x1,stu y1){
        if(x1.x!=y1.x)
            return x1.x<y1.x;
        else if(x1.a!=y1.a){
            return x1.a<y1.a;
        }
        return x1.b<y1.b;
    } 
    
    int find(int x){
        if(x==pre[x]) return x;
        return pre[x]=find(pre[x]);
    }
    void join(int x,int y){
        int fx=find(x),fy=find(y);
        if(fx!=fy){
            pre[fx]=fy;
        }
    }
    
    
    int main(){
        int n;
        cin>>n;
    
        for(int i=1;i<=n;i++){
            pre[i]=i;
        }
        
        for(int i=1;i<=n;i++){
            scanf("%d%d",&p[i].a,&p[i].b);
        }
        
        int pos=0;
        for(int i=1;i<n;i++){
            for(int j=i+1;j<=n;j++){
                pp[pos].a=i;//i号城市 
                pp[pos].b=j;//j号城市 
                pp[pos].x=(p[i].a-p[j].a)*(p[i].a-p[j].a)+(p[i].b-p[j].b)*(p[i].b-p[j].b);//i号城市到j号城市的距离
                pos++; 
            }
        }
        sort(pp,pp+pos,cmp);
        int m;
        cin>>m;
        int xx,yy;
        for(int j=1;j<=m;j++) {
            scanf("%d%d",&xx,&yy);
            join(xx,yy);
        }
        for(int i=0;i<pos;i++){
            int fx=find(pp[i].a);
            int fy=find(pp[i].b);
            if(fx!=fy){
                pre[fx]=fy;
                cout<<pp[i].a<<" "<<pp[i].b<<endl;
            }
        }
        return 0;
    } 



  • 相关阅读:
    查找符号链接的目标
    升级到VS2013.Update.4的问题
    (转载)FT232RL通信中断问题解决办法总结
    WinForms中的Label的AutoSize属性
    VS2010中的查找和替换中正则的使用
    为什么SqlTransaction.Rollback会抛出SqlException(11,-2)(即SQL超时异常)
    腾讯内推 社会招聘 自助操作内推
    腾讯内推流程 社会招聘 腾讯面试流程
    golang sort包的使用(一)
    golang 结构体中空数组被序列化成null解决方法
  • 原文地址:https://www.cnblogs.com/Accepting/p/11310795.html
Copyright © 2011-2022 走看看