zoukankan      html  css  js  c++  java
  • Candy Distribution

    Kids like candies, so much that they start beating each other if the candies are not fairly distributed. So on your next party, you better start thinking before you buy the candies.

    If there are KK kids, we of course need KXK⋅X candies for a fair distribution, where XX is a positive natural number. But we learned that always at least one kid looses one candy, so better be prepared with exactly one spare candy, resulting in (KX)+1(K⋅X)+1 candies.

    Usually, the candies are packed into bags with a fixed number of candies CC. We will buy some of these bags so that the above constraints are fulfilled.

    Input

    The first line gives the number of test cases tt (0<t<1000<t<100). Each test case is specified by two integers KK and CC on a single line, where KK is the number of kids and CC the number of candies in one bag (1K,C1091≤K,C≤109). As you money is limited, you will never buy more than 109109 candy bags.

    Output

    For each test case, print one line. If there is no such number of candy bugs to fulfill the above constraints, print “IMPOSSIBLE” instead. Otherwise print the number of candy bags, you want to buy. If there is more than one solution, any will do.

    Sample Input 1Sample Output 1
    5
    10 5
    10 7
    1337 23
    123454321 42
    999999937 142857133
    
    IMPOSSIBLE
    3
    872
    14696943
    166666655

    题解:就是求一个不定方程 k*x-c*y=1  有几个注意的地方 对c==1的情况进行特判  不能有puts输出 还有就是不能有(x%d+d)%d来更新x

    #include<iostream>
    #include<cstring>
    #include<cstdio> 
    using namespace std;
    typedef long long ll;
    ll exgcd(ll a,ll b,ll &x,ll &y){
        if(b==0){
            x=1;
            y=0;
            return a;
        }
        ll r=exgcd(b,a%b,x,y);
        ll t=y;
        y=x-(a/b)*y;
        x=t;
        return r;
    }
    int main(){
        ios::sync_with_stdio(false);
        ll t;
        cin>>t;
        while(t--){
            ll k,c;
            cin>>k>>c;
            ll x,y;
            ll r=exgcd(c,k,x,y);
            if(r!=1){
    //            puts("IMPOSSIBLE");
                cout<<"IMPOSSIBLE"<<'
    ';
            }
            else {
                if(c==1) {
                    cout<<k+1<<'
    ';
                }
                else{
                    while(x<=0) x+=k;
                    cout<<x<<'
    ';
                }
            }
        }
        return 0; 
    }   

     

  • 相关阅读:
    SSH框架总结
    SSM框架——详细整合教程(Spring+SpringMVC+MyBatis)
    iBATIS SQL Maps
    深入理解Mybatis中sqlSessionFactory机制原理
    mybatis源码分析(1)——SqlSessionFactory实例的产生过程
    MyBatis常用对象SqlSessionFactory和SqlSession介绍和运用
    Generator生成器函数
    MyBatis学习4---使用MyBatis_Generator生成Dto、Dao、Mapping
    采用图形用户界面的操作系统/应用程序
    图形界面的特点是人们不需要记忆和键入繁琐的命令
  • 原文地址:https://www.cnblogs.com/Accepting/p/11355352.html
Copyright © 2011-2022 走看看