zoukankan      html  css  js  c++  java
  • 迷宫问题 POJ 3984

    题目

    定义一个二维数组:

    int maze[5][5] = {
    
    	0, 1, 0, 0, 0,
    
    	0, 1, 0, 1, 0,
    
    	0, 0, 0, 0, 0,
    
    	0, 1, 1, 1, 0,
    
    	0, 0, 0, 1, 0,
    
    };
    

    它表示一个迷宫,其中的1表示墙壁,0表示可以走的路,只能横着走或竖着走,不能斜着走,要求编程序找出从左上角到右下角的最短路线。

    Input

    一个5 × 5的二维数组,表示一个迷宫。数据保证有唯一解。

    Output

    左上角到右下角的最短路径,格式如样例所示。

    Sample Input

    0 1 0 0 0
    0 1 0 1 0
    0 0 0 0 0
    0 1 1 1 0
    0 0 0 1 0

    Sample Output

    (0, 0)
    (1, 0)
    (2, 0)
    (2, 1)
    (2, 2)
    (2, 3)
    (2, 4)
    (3, 4)
    (4, 4)

    代码

    #include <iostream>
    #include <cstring>
    #include <stack>
    using namespace std;
    struct queue_point
    {
    	int x,y,steps,father;
    }queue[30];
    int map[6][6],head=0,tail=0,step=0;
    bool visited[6][6];
    void kuozhan(int x,int y)
    {
    	visited[x][y]=true;
    	queue[tail].x=x;
    	queue[tail].y=y;
    	queue[tail].steps=step+1;
    	queue[tail].father=head-1;
    	tail++;
    }
    int main()
    {
    	memset(map,0,sizeof(map));
    	memset(visited,0,sizeof(visited));
    	for(int i=1;i<=5;i++)
    		for(int j=1;j<=5;j++)
    			cin>>map[i][j];
    	queue[tail].x=1;
    	queue[tail].y=1;
    	queue[tail].steps=0;
    	queue[tail].father=-1;
    	visited[1][1]=true;
    	tail++;
    	while(head!=tail)
    	{
    		queue_point s=queue[head++];
    		if(s.x==5&&s.y==5)
    		{
    			stack<queue_point> temp;
    			temp.push(s);
    			while(s.father!=-1)
    			{
    				s=queue[s.father];
    				temp.push(s);
    			}
    			while(!temp.empty())
    			{
    				cout<<'('<<temp.top().x-1<<", "<<temp.top().y-1<<')'<<endl;
    				temp.pop();
    			}
    			return 0;
    		}
    		if(s.x+1<=5&&!visited[s.x+1][s.y]&&map[s.x+1][s.y]==0) kuozhan(s.x+1,s.y);
    		if(s.y+1<=5&&!visited[s.x][s.y+1]&&map[s.x][s.y+1]==0) kuozhan(s.x,s.y+1);
    		if(s.x-1>=1&&!visited[s.x-1][s.y]&&map[s.x-1][s.y]==0) kuozhan(s.x-1,s.y);
    		if(s.y-1>=1&&!visited[s.x][s.y-1]&&map[s.x][s.y-1]==0) kuozhan(s.x,s.y-1);
    	}
    	return 0;
    }
    
  • 相关阅读:
    sun.misc.BASE64Encoder找不到的解决方法
    eclipse里大小写转化的快捷键是什么
    jface viewer 理解
    如何在遗留代码基础上开发
    谈谈技术文档的编写
    jre build path 中的限制问题导致一些代码无法编译..如果设置
    android update automatically ( android 自动升级)
    各大集群存储产品点评
    关于@Autowired 注释为何不需要get Set
    VRML之desk
  • 原文地址:https://www.cnblogs.com/AlexKing007/p/12338582.html
Copyright © 2011-2022 走看看