zoukankan      html  css  js  c++  java
  • Quick Brown Fox

    Quick Brown Fox时间限制: 1 Sec  内存限制: 128 MB

    题目描述

    A pangram is a phrase that includes at least one occurrence of each of the 26 letters, ‘a’. . .‘z’. You’re probably familiar with this one: “The quick brown fox jumps over the lazy dog.”
    Your job is to recognize pangrams. For phrases that don’t contain every letter, report what letters are missing. We’ll say that a particular letter occurs in the phrase if it occurs as either upper case or lower case.

    输入

    Input starts with a line containing an integer 1 ≤ N ≤ 50. The next N lines are each a single phrase,possibly containing upper and lower case letters, spaces, decimal digits and punctuation characters ‘.’,‘,’, ‘?’, ‘!’, ‘’’ and ‘"’. Each phrase contains at least one and no more than 100 characters.

    输出

    For each input phrase, output “pangram” if it qualifies as a pangram. Otherwise, output the word “missing” followed by a space and then the list of letters that didn’t occur in the phrase. The list of missing letters should be reported in lower case and should be sorted alphabetically.

    样例输入

    3
    The quick brown fox jumps over the lazy dog.
    ZYXW, vu TSR Ponm lkj ihgfd CBA.
    .,?!’" 92384 abcde FGHIJ
    

    样例输出

    pangram
    missing eq
    missing klmnopqrstuvwxyz


    #include<stdio.h>
    #include<string.h>
    int main()
    {
        char a[53],s[100];
        int i,j=0,n,count;
        int N;
        int book[26];
        for(i=0;i<26;i++)
        {
            a[i]='a'+i;
        }
        for(i=26;i<52;i++)
        {
            a[i]='A'+i-26;
        }
       printf("%c\n",a[51]);
       // puts(a);
       scanf("%d",&N);
       while(N--)
       {
           getchar();
           gets(s);
          n=strlen(s);
          for(i=0;i<26;i++)
            book[i]=0;
        for(i=0;i<n;i++)
        {
            for(j=0;j<52;j++)
            { if(s[i]==a[j]&&j<26)
                  book[j]++;
                  if(s[i]==a[j]&&j>=26)
                    book[j-26]++;
              }
        }
        for(i=0;i<26;i++)
        printf("%d ",book[i]);
        for(i=0;i<26;i++)
        {
            if(book[i]!=0)
                count++;
        }
        if(count==26)
            printf("pangram\n");

            if(count!=26)
            {
                printf("missing ");
            for(i=0;i<26;i++)
            {
                if(book[i]==0)
                printf("%c",a[i]);
            }
            printf("\n");
            }
       }
            return 0;
    }








  • 相关阅读:
    20170602
    使用布局规划页面
    商品的删除
    修改页面的 修改图片
    商品修改
    引入行高亮显示
    添加一个时间插件: 1.把插件放到 public目录 下 datetimepicker
    排序,搜索 代码
    搜索
    翻页代码,商品列表页;
  • 原文地址:https://www.cnblogs.com/AquamarineOnly/p/5573912.html
Copyright © 2011-2022 走看看