zoukankan      html  css  js  c++  java
  • HDU 2844 Coins[【经典题】【模板题】

    Coins

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 15971    Accepted Submission(s): 6340


    Problem Description
    Whuacmers use coins.They have coins of value A1,A2,A3...An Silverland dollar. One day Hibix opened purse and found there were some coins. He decided to buy a very nice watch in a nearby shop. He wanted to pay the exact price(without change) and he known the price would not more than m.But he didn't know the exact price of the watch.

    You are to write a program which reads n,m,A1,A2,A3...An and C1,C2,C3...Cn corresponding to the number of Tony's coins of value A1,A2,A3...An then calculate how many prices(form 1 to m) Tony can pay use these coins.
     

    Input
    The input contains several test cases. The first line of each test case contains two integers n(1 ≤ n ≤ 100),m(m ≤ 100000).The second line contains 2n integers, denoting A1,A2,A3...An,C1,C2,C3...Cn (1 ≤ Ai ≤ 100000,1 ≤ Ci ≤ 1000). The last test case is followed by two zeros.
     

    Output
    For each test case output the answer on a single line.
     

    Sample Input
    3 10 1 2 4 2 1 1 2 5 1 4 2 1 0 0
     

    Sample Output
    8 4
     

    Source


    多重背包

    #include<iostream>  
    #include<algorithm>
    #include<cmath>
    #include<cstdio>
    #include<cstdlib>
    #include<queue>
    #include<map>
    #include<set>
    #include<stack>
    #include<bitset>
    #include<numeric>
    #include<vector>
    #include<string>
    #include<iterator>
    #include<cstring>
    #include<functional>
    #define INF 0x3f3f3f3f
    #define ms(a,b) memset(a,b,sizeof(a))
    #define pi 3.14159265358979
    #define mod 1000000007
    #define maxn 100010
    using namespace std;
    typedef pair<int, int> P;
    typedef long long ll;
    typedef unsigned long long ull;
    int n, m, c[maxn], v[maxn], d[maxn];
    void zeroonepack(int cost, int weight)
    {
        for (int i = m; i >= cost; i--)
        {
            d[i] = max(d[i], d[i - cost] + weight);
        }
    }
    void completepack(int cost, int weight)
    {
        for (int i = cost; i <= m; i++)
        {
            d[i] = max(d[i], d[i - cost] + weight);
        }
    }
    void multipack(int cost, int weight, int amount)
    {
        if (cost*amount >= m)
            completepack(cost, weight);
        else
        {
            int k = 1;
            while (k <= amount)
            {
                zeroonepack(k*cost, k*weight);
                amount -= k;
                k *= 2;
            }
            zeroonepack(amount*cost, amount*weight);
        }
    }
    int main()
    {
        while (cin >> n >> m)
        {
            if (!n && !m) break;
            ms(d, 0);
            for (int i = 0; i < n; i++)
            {
                cin >> v[i];
            }
            for (int i = 0; i < n; i++)
            {
                cin >> c[i];
            }
            for (int i = 0; i < n; i++)
            {
                multipack(v[i], v[i], c[i]);
            }
            int sum = 0;
            for (int i = 1; i <= m; i++)
            {
                if (d[i] == i)
                    sum++;
            }
            cout << sum << endl;
        }
    }



    Fighting~
  • 相关阅读:
    C# Guid should contain 32 digits with 4 dashes (xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx).
    C# Collection was modified;enumeration operation may not execute
    C# 写文件
    AJAX 入门教程
    ABP 软删除ISoftDelete
    C# 随机列表
    C# ConfigurationManager 类的使用
    mui 关闭当前窗口
    C# 委托
    VSTO:使用C#开发Excel、Word【13】
  • 原文地址:https://www.cnblogs.com/Archger/p/12774720.html
Copyright © 2011-2022 走看看