zoukankan      html  css  js  c++  java
  • HDU 6140 Hybrid Crystals【阅读题】【水题】

    Hybrid Crystals

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
    Total Submission(s): 161    Accepted Submission(s): 81


    Problem Description
    > Kyber crystals, also called the living crystal or simply the kyber, and known as kaiburr crystals in ancient times, were rare, Force-attuned crystals that grew in nature and were found on scattered planets across the galaxy. They were used by the Jedi and the Sith in the construction of their lightsabers. As part of Jedi training, younglings were sent to the Crystal Caves of the ice planet of Ilum to mine crystals in order to construct their own lightsabers. The crystal's mix of unique lustre was called "the water of the kyber" by the Jedi. There were also larger, rarer crystals of great power and that, according to legends, were used at the heart of ancient superweapons by the Sith.
    >
    > — Wookieepedia

    Powerful, the Kyber crystals are. Even more powerful, the Kyber crystals get combined together. Powered by the Kyber crystals, the main weapon of the Death Star is, having the firepower of thousands of Star Destroyers.

    Combining Kyber crystals is not an easy task. The combination should have a specific level of energy to be stablized. Your task is to develop a Droid program to combine Kyber crystals.

    Each crystal has its level of energy (i-th crystal has an energy level of ai). Each crystal is attuned to a particular side of the force, either the Light or the Dark. Light crystals emit positive energies, while dark crystals emit negative energies. In particular,

    * For a light-side crystal of energy level ai, it emits +ai units of energy.
    * For a dark-side crystal of energy level ai, it emits ai units of energy.

    Surprisingly, there are rare neutral crystals that can be tuned to either dark or light side. Once used, it emits either +ai or ai units of energy, depending on which side it has been tuned to.

    Given n crystals' energy levels ai and types bi (1in), bi=N means the i-th crystal is a neutral one, bi=L means a Light one, and bi=D means a Dark one. The Jedi Council asked you to choose some crystals to form a larger hybrid crystal. To make sure it is stable, the final energy level (the sum of the energy emission of all chosen crystals) of the hybrid crystal must be exactly k.

    Considering the NP-Hardness of this problem, the Jedi Council puts some additional constraints to the array such that the problem is greatly simplified.

    First, the Council puts a special crystal of a1=1,b1=N.

    Second, the Council has arranged the other n1 crystals in a way that
    aij=1i1aj[bj=N]+j=1i1aj[bi=Lbj=L]+j=1i1aj[bi=Dbj=D](2in).

    [cond] evaluates to 1 if cond holds, otherwise it evaluates to 0.

    For those who do not have the patience to read the problem statements, the problem asks you to find whether there exists a set S{1,2,,n} and values si for all iS such that

    iSaisi=k,


    where si=1 if the i-th crystal is a Light one, si=1 if the i-th crystal is a Dark one, and si{1,1} if the i-th crystal is a neutral one.
     

    Input
    The first line of the input contains an integer T, denoting the number of test cases.

    For each test case, the first line contains two integers n (1n103) and k (|k|106). 

    The next line contains n integer a1,a2,...,an (0ai103).

    The next line contains n character b1,b2,...,bn (bi{L,D,N}).
     

    Output
    If there exists such a subset, output "yes", otherwise output "no".
     

    Sample Input
    2 5 9 1 1 2 3 4 N N N N N 6 -10 1 0 1 2 3 1 N L L L L D
     

    Sample Output
    yes no
     

    Source

    #include <bits/stdc++.h>
    #define INF 0x3f3f3f3f
    #define ms(x,y) memset(x,y,sizeof(x))
    using namespace std;
    
    typedef long long ll;
    
    const double pi = acos(-1.0);
    const int mod = 1e9 + 7;
    const int maxn = 1e3 + 10;
    
    int a[maxn];
    char b[maxn];
    
    int main()
    {
        //freopen("in.txt","r",stdin);
        //freopen("out.txt","w",stdout);
        int t;
        scanf("%d",&t);
        while(t--)
        {
            int n,k;
            scanf("%d%d",&n,&k);
            for(int i=0;i<n;i++)
            {
                scanf("%d",a+i);
            }
            for(int i=0;i<n;i++)
            {
                scanf(" %c",b+i);
            }
            int l=0,r=0;
            for(int i=0;i<n;i++)
            {
                if(b[i]=='L') r+=a[i];
                else if(b[i]=='D') l-=a[i];
                else
                {
                    l-=a[i];
                    r+=a[i];
                }
            }
            if(k>=l&&k<=r)
            {
                puts("yes");
            }
            else puts("no");
        }
        return 0;
    }


    Fighting~
  • 相关阅读:
    [CQOI2011]放棋子
    [CF1192B]动态直径
    [CERC2016]凸轮廓线
    19_08_14-19_08_21校内训练 补题
    [模板]线性递推+BM
    19_08_10[校内训练]割图
    [模板]多项式封装(无讲解)
    19_07_11校内训练[字串染色]
    CF990G
    19_07_09校内训练[分组]
  • 原文地址:https://www.cnblogs.com/Archger/p/8451576.html
Copyright © 2011-2022 走看看