zoukankan      html  css  js  c++  java
  • ACM题目————Aggressive cows

    Description

    Farmer John has built a new long barn, with N (2 <= N <= 100,000) stalls. The stalls are located along a straight line at positions x1,...,xN (0 <= xi <= 1,000,000,000).

    His C (2 <= C <= N) cows don't like this barn layout and become aggressive towards each other once put into a stall. To prevent the cows from hurting each other, FJ want to assign the cows to the stalls, such that the minimum distance between any two of them is as large as possible. What is the largest minimum distance?

    Input

    * Line 1: Two space-separated integers: N and C

    * Lines 2..N+1: Line i+1 contains an integer stall location, xi

    Output

    * Line 1: One integer: the largest minimum distance

    Sample Input

    5 3
    1
    2
    8
    4
    9

    Sample Output

    3

    Hint

    OUTPUT DETAILS:

    FJ can put his 3 cows in the stalls at positions 1, 4 and 8, resulting in a minimum distance of 3.

    Huge input data,scanf is recommended.
     
    要把题目读懂!
     
    二分枚举
    代码:
    #include <iostream>
    #include <algorithm>
    
    using namespace std;
    const long long INF = 1000000002;
    int a[100002], C, n;
    
    bool OK(int m)
    {
        int last = 0;
        for(int i=1; i<C; i++)
        {
            int cur = last + 1 ;
            while(cur<n && a[cur]-a[last]<m) cur ++ ;
            if(cur==n) return false ;
            last = cur ;
        }
        return true;
    }
    
    int main()
    {
        cin >> n >> C ;
        for(int i=0; i<n; i++) cin >> a[i] ;
        sort(a,a+n);//排序
        int low = 0, high = a[n-1] + 1 ;
        while(high - low > 1)
        {
            int mid =  (low + high) >> 1 ;
            if(OK(mid)) low = mid ;
            else high = mid ;
        }
        cout << low << endl ;
    
        return 0;
    }
    


    低调做人,高调做事。
  • 相关阅读:
    acm寒假特辑1月20日 CodeForces
    acm寒假特辑1月24日 HDU
    acm寒假特辑1月25日HDU
    acm寒假特辑1月26日HDU
    acm寒假特辑1月22日HDU
    acm寒假特辑1月28日HDU
    ubuntu14.04安装notepadqq
    ntpd vs. ntpdate
    centos7 防火墙firewalld
    git 自动补全 (git auto completion)
  • 原文地址:https://www.cnblogs.com/Asimple/p/5478236.html
Copyright © 2011-2022 走看看