zoukankan      html  css  js  c++  java
  • ACM题目————Subsequence

    Description

    A sequence of N positive integers (10 < N < 100 000), each of them less than or equal 10000, and a positive integer S (S < 100 000 000) are given. Write a program to find the minimal length of the subsequence of consecutive elements of the sequence, the sum of which is greater than or equal to S.

    Input

    The first line is the number of test cases. For each test case the program has to read the numbers N and S, separated by an interval, from the first line. The numbers of the sequence are given in the second line of the test case, separated by intervals. The input will finish with the end of file.

    Output

    For each the case the program has to print the result on separate line of the output file.if no answer, print 0.

    Sample Input

    2
    10 15
    5 1 3 5 10 7 4 9 2 8
    5 11
    1 2 3 4 5

    Sample Output

    2
    3

    题目大意:

    求数组连续元素和大于等于K 的最小连续个数!

    代码:

    #include <iostream>
    
    using namespace std;
    
    int a[100005];
    
    int main()
    {
        int T, n, K, pos, low, minn;
        cin >> T ;
        while(T--)
        {
            cin >> n >> K ;
            minn = n ;
            int sum = 0;
            low = 0;
            pos = 0;
            for(int i=0; i<n; i++) cin >> a[i] ;
            for( ; ; ++ low)
            {
                while(sum<=K && pos < n) sum += a[pos++] ;
                if(sum<K) break ;
                sum -= a[low];
                minn = min(minn,pos-low);
            }
            if(minn==n) cout << "0" << endl ;
            else cout << minn << endl ;
        }
    
        return 0;
    }
    
    低调做人,高调做事。
  • 相关阅读:
    echarts-detail---饼图
    echarts-detail--柱状图
    mvc5 错误页如何定义
    MyEclipse编码设置
    java EE 5 Libraries 删掉后怎么重新导入
    Server Library [Apache Tomcat v6.0](unbound)服务未绑定解决办法
    免安装jdk 和 免安装tomcat
    group_concat
    java cookie
    java 分割split
  • 原文地址:https://www.cnblogs.com/Asimple/p/5479430.html
Copyright © 2011-2022 走看看