zoukankan      html  css  js  c++  java
  • ACM题目————Find them, Catch them

    Description

    The police office in Tadu City decides to say ends to the chaos, as launch actions to root up the TWO gangs in the city, Gang Dragon and Gang Snake. However, the police first needs to identify which gang a criminal belongs to. The present question is, given two criminals; do they belong to a same clan? You must give your judgment based on incomplete information. (Since the gangsters are always acting secretly.)

    Assume N (N <= 10^5) criminals are currently in Tadu City, numbered from 1 to N. And of course, at least one of them belongs to Gang Dragon, and the same for Gang Snake. You will be given M (M <= 10^5) messages in sequence, which are in the following two kinds:

    1. D [a] [b]
    where [a] and [b] are the numbers of two criminals, and they belong to different gangs.

    2. A [a] [b]
    where [a] and [b] are the numbers of two criminals. This requires you to decide whether a and b belong to a same gang.

    Input

    The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. Each test case begins with a line with two integers N and M, followed by M lines each containing one message as described above.

    Output

    For each message "A [a] [b]" in each case, your program should give the judgment based on the information got before. The answers might be one of "In the same gang.", "In different gangs." and "Not sure yet."

    Sample Input

    1
    5 5
    A 1 2
    D 1 2
    A 1 2
    D 2 4
    A 1 4
    

    Sample Output

    Not sure yet.
    In different gangs.
    In the same gang.
    

    并查集的扩展。

    //Asimple
    #include <iostream>
    #include <cstdio>
    
    using namespace std;
    const int maxn = 100010;
    int fa[maxn];//存贮根    fa[a] 存 a 的根
    int r[maxn];// 存贮 fa[a] 与 a 的关系
    // 0 则不在一个 gang 里, 1 表示在一个 gang 里
    int T, n, m, a, b;
    char ch;
    
    void make_set(int n)// 保存根
    {
        for(int i=1; i<=n; i++)
        {
            fa[i] = i ;// i 的根是 fa[i]
            r[i] = 1 ;//  在同一个 gang 里
        }
    }
    
    int find_set(int a)//  找根节点
    {
        if( a == fa[a] ) return a;
        else
        {
            int temp = fa[a] ;
            fa[a] = find_set(fa[a]);
            r[a] = (r[temp] + r[a] + 1 ) % 2 ;
        }
        return fa[a] ;
    }
    
    void union_set(int a, int b)
    {
        int faa = find_set(a);//找根节点
        int fbb = find_set(b);
        if( faa != fbb )//两个根节点不同,就将其联合起来
        {
            fa[faa] = fbb ;
            r[faa] = ( r[a] + r[b] ) % 2 ;//更新状态
        }
    }
    
    
    int main()
    {
        scanf("%d",&T);
        while( T -- )
        {
            scanf("%d%d",&n,&m);
            make_set(n);
            while( m-- )
            {
                getchar();
                scanf("%c%d%d",&ch,&a,&b);
                if( ch == 'A' )
                {
                    if( find_set(a) == find_set(b) )
                    {
                        if((r[a]+r[b])%2==0) cout << "In the same gang." << endl ;
                        else cout << "In different gangs." << endl ;
                    }
                    else cout << "Not sure yet." << endl ;
                }
                else union_set(a,b);
            }
        }
    
        return 0;
    }
    
    低调做人,高调做事。
  • 相关阅读:
    DNS服务器配置
    动态网站技术CGI
    SED单行脚本快速参考(Unix 流编辑器)
    xen 安静的角落
    IP命令
    oracle 监听文件 说明
    LRU ,LRUW,CKPT-Q
    重建控制文件ORA-12720
    历史备份控制文件恢复数据库
    增量检查点和完全检查点
  • 原文地址:https://www.cnblogs.com/Asimple/p/5512368.html
Copyright © 2011-2022 走看看