zoukankan      html  css  js  c++  java
  • ACM编程POJ 1837 Balance(动态规划之背包问题)

    Balance
    Time Limit:1000MS   Memory Limit:30000K
    Total Submissions:4309   Accepted:2521

    Description

    Gigel has a strange "balance" and he wants to poise it. Actually, the device is different from any other ordinary balance.
    It orders two arms of negligible weight and each arm's length is 15. Some hooks are attached to these arms and Gigel wants to hang up some weights from his collection of G weights (1 <= G <= 20) knowing that these weights have distinct values in the range 1..25. Gigel may droop any weight of any hook but he is forced to use all the weights.
    Finally, Gigel managed to balance the device using the experience he gained at the National Olympiad in Informatics. Now he would like to know in how many ways the device can be balanced.

    Knowing the repartition of the hooks and the set of the weights write a program that calculates the number of possibilities to balance the device.
    It is guaranteed that will exist at least one solution for each test case at the evaluation.

    Input

    The input has the following structure:
    • the first line contains the number C (2 <= C <= 20) and the number G (2 <= G <= 20);
    • the next line contains C integer numbers (these numbers are also distinct and sorted in ascending order) in the range -15..15 representing the repartition of the hooks; each number represents the position relative to the center of the balance on the X axis (when no weights are attached the device is balanced and lined up to the X axis; the absolute value of the distances represents the distance between the hook and the balance center and the sign of the numbers determines the arm of the balance to which the hook is attached: '-' for the left arm and '+' for the right arm);
    • on the next line there are G natural, distinct and sorted in ascending order numbers in the range 1..25 representing the weights' values.

    Output

    The output contains the number M representing the number of possibilities to poise the balance.

    Sample Input

    2 4	
    -2 3 
    3 4 5 8
    

    Sample Output

    2

    #define _CRT_SECURE_NO_DEPRECATE
    #include<stdio.h>
    #include<Windows.h>
    //2 4
    //- 2 3
    //3 4 5 8
    //考察动态规划,opt[i][j]表示挂前i个砝码后重量因子为j的方法数
    //15*20*25=7500   7500*2=15000
    //动态规划关键就是找出子结构,和状态转移方程,边界条件
    //输入钩码位置个数,钩码的数量,位置信息和重量信息
    int opt[21][15001];//默认全为0
    int c[21], g[21];//钩码位置信息和重量信息
    int main()
    {
        
        int C, G;//挂钩数量和钩码数量
        int i, j, k;
        
        scanf("%d %d", &C, &G);
        for (i = 0; i<C; i++)
            scanf("%d", &c[i]);
        for (j = 0; j<G; j++)
            scanf("%d", &g[j]);
        opt[0][7500] = 1;//初始状态,没有砝码的情况下,也平衡,故将其设置为1
        
        for (i = 1; i <= G; i++)//每一行
        {
            for (j = 1; j <= 15000; j++)//每一列
            {
                if (opt[i - 1][j] != 0)//表示前i-1个砝码挂上后存在平衡因子为j的平衡的方式,数组存储平衡状态数量
                {
                    //计算出挂上第i个砝码后,将其放在不同的位置产生的对应平衡因子的可能悬挂情况
                    //上一行影响后面的行,之探讨新加进来的第i个钩码,之前的都探讨完了
                    for (k = 0; k<C; k++)
                        opt[i][j + c[k] * g[i - 1]] += opt[i - 1][j];
                }
            }
        }
        printf("%d", opt[G][7500]);//7500为平衡因子
        system("pause");
        return 0;
    }
    
    
    
     
  • 相关阅读:
    JDK路径下目录的介绍及环境变量配置
    Eclipse显示或隐藏项目
    linux 上传文件 rz命令 提示command not found 解决方法
    Query failed with error code 96 and error message 'Executor error during find command: OperationFailed: Sort operation used more than the maximum 33554432 bytes of RAM. Add an index, or specify a smal
    eclipse设置类和方的注释模板
    Xml 将一个Xml字节流写入到Dataset里面
    C# List<object> 转换为List<string>、转换为 string数组、转换为一个字符串用分隔符 隔开
    SQL 把m或f,更改为男女
    C# 去掉字符串里的分隔符(该分隔符可以是一个字符串)
    C# 通过一个开始时间和结束时间 按【AddDays】拆分成一个数组
  • 原文地址:https://www.cnblogs.com/BetterThanEver_Victor/p/6363642.html
Copyright © 2011-2022 走看看