zoukankan      html  css  js  c++  java
  • HDU——1062Text Reverse(水题string::find系列+reverse)

    Text Reverse

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 24157    Accepted Submission(s): 9311


    Problem Description
    Ignatius likes to write words in reverse way. Given a single line of text which is written by Ignatius, you should reverse all the words and then output them.
     


     

    Input
    The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
    Each test case contains a single line with several words. There will be at most 1000 characters in a line.
     


     

    Output
    For each test case, you should output the text which is processed.
     


     

    Sample Input
    3 olleh !dlrow m'I morf .udh I ekil .mca
     


     

    Sample Output
    hello world! I'm from hdu. I like acm.
    Hint
    Remember to use getchar() to read ' ' after the interger T, then you may use gets() to read a line and process it.

    刚开始发现最后一个单词和前一个连在一块了,改了一个地方就过了,本打算用stringstream重定向,想想好麻烦der,还是用最喜欢的string系列函数吧.还好string支持加号运算

    代码:

    #include<iostream>
    #include<cmath>
    #include<algorithm>
    #include<string>
    using namespace std;
    int main(void)
    {
        int t,loc;
        cin>>t;
        getchar();
        string s1;    
        while (t--)
        {
            getline(cin,s1);
            loc=0;
            while (s1.find(" ",loc)!=string::npos)//反转前n-1个单词
            {
                reverse( s1.begin()+loc , s1.begin()+s1.find(" ",loc) );
                loc=s1.find(" ",loc)+1;//更新每次反转的begin位置
            }
            reverse( s1.begin()+s1.find_last_of(" ")+1 , s1.end() );//反转最后一个单词
            cout<<s1<<endl;
        }
        return 0;
    }
  • 相关阅读:
    PHP安全
    使用 jQuery 简化 Ajax 开发
    我的云之旅–HBase调试(139)
    Java的性能调优
    libsqlite3.dylib与libsqlite3.0.dylib区别
    zookeeper code
    最近的一个框架
    我的云之旅–Lucene内容存储进入Hadoop(136)
    Linux源码阅读推荐阅读图书
    我的云之旅–HMaster启动说明(140)
  • 原文地址:https://www.cnblogs.com/Blackops/p/5356424.html
Copyright © 2011-2022 走看看