zoukankan      html  css  js  c++  java
  • HDU——1062Text Reverse(水题string::find系列+reverse)

    Text Reverse

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 24157    Accepted Submission(s): 9311


    Problem Description
    Ignatius likes to write words in reverse way. Given a single line of text which is written by Ignatius, you should reverse all the words and then output them.
     


     

    Input
    The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
    Each test case contains a single line with several words. There will be at most 1000 characters in a line.
     


     

    Output
    For each test case, you should output the text which is processed.
     


     

    Sample Input
    3 olleh !dlrow m'I morf .udh I ekil .mca
     


     

    Sample Output
    hello world! I'm from hdu. I like acm.
    Hint
    Remember to use getchar() to read ' ' after the interger T, then you may use gets() to read a line and process it.

    刚开始发现最后一个单词和前一个连在一块了,改了一个地方就过了,本打算用stringstream重定向,想想好麻烦der,还是用最喜欢的string系列函数吧.还好string支持加号运算

    代码:

    #include<iostream>
    #include<cmath>
    #include<algorithm>
    #include<string>
    using namespace std;
    int main(void)
    {
        int t,loc;
        cin>>t;
        getchar();
        string s1;    
        while (t--)
        {
            getline(cin,s1);
            loc=0;
            while (s1.find(" ",loc)!=string::npos)//反转前n-1个单词
            {
                reverse( s1.begin()+loc , s1.begin()+s1.find(" ",loc) );
                loc=s1.find(" ",loc)+1;//更新每次反转的begin位置
            }
            reverse( s1.begin()+s1.find_last_of(" ")+1 , s1.end() );//反转最后一个单词
            cout<<s1<<endl;
        }
        return 0;
    }
  • 相关阅读:
    [leetcode]7. Reverse Integer
    [leetcode] 6. ZigZag Conversion
    [leetcode] 5.Longest Palindromic Substring-2
    [leetcode] 5.Longest Palindromic Substring-1
    [leetcode]4. Median of Two Sorted Arrays
    [leetcode]3. Longest Substring Without Repeating Characters
    [leetcode]2. Add Two Numbers
    [chrome]download chrome offline installer package / 下载chrome离线安装包
    [powershell]powershell upgrade package
    [python]python cockbook
  • 原文地址:https://www.cnblogs.com/Blackops/p/5356424.html
Copyright © 2011-2022 走看看