zoukankan      html  css  js  c++  java
  • POJ——2236Wireless Network(暴力并查集)

    Wireless Network
    Time Limit: 10000MS   Memory Limit: 65536K
    Total Submissions: 22107   Accepted: 9285

    Description

    An earthquake takes place in Southeast Asia. The ACM (Asia Cooperated Medical team) have set up a wireless network with the lap computers, but an unexpected aftershock attacked, all computers in the network were all broken. The computers are repaired one by one, and the network gradually began to work again. Because of the hardware restricts, each computer can only directly communicate with the computers that are not farther than d meters from it. But every computer can be regarded as the intermediary of the communication between two other computers, that is to say computer A and computer B can communicate if computer A and computer B can communicate directly or there is a computer C that can communicate with both A and B. 

    In the process of repairing the network, workers can take two kinds of operations at every moment, repairing a computer, or testing if two computers can communicate. Your job is to answer all the testing operations. 

    Input

    The first line contains two integers N and d (1 <= N <= 1001, 0 <= d <= 20000). Here N is the number of computers, which are numbered from 1 to N, and D is the maximum distance two computers can communicate directly. In the next N lines, each contains two integers xi, yi (0 <= xi, yi <= 10000), which is the coordinate of N computers. From the (N+1)-th line to the end of input, there are operations, which are carried out one by one. Each line contains an operation in one of following two formats: 
    1. "O p" (1 <= p <= N), which means repairing computer p. 
    2. "S p q" (1 <= p, q <= N), which means testing whether computer p and q can communicate. 

    The input will not exceed 300000 lines. 

    Output

    For each Testing operation, print "SUCCESS" if the two computers can communicate, or "FAIL" if not.

    Sample Input

    4 1
    0 1
    0 2
    0 3
    0 4
    O 1
    O 2
    O 4
    S 1 4
    O 3
    S 1 4
    

    Sample Output

    FAIL
    SUCCESS

    没看时间是10s,搞半天原来是暴力。那简单了,每次修复一个机器的时候遍历查询能否和其他已经修好的进行合并即可

    代码:

    #include<iostream>
    #include<algorithm>
    #include<cstdlib>
    #include<sstream>
    #include<cstring>
    #include<cstdio>
    #include<string>
    #include<deque>
    #include<stack>
    #include<cmath>
    #include<queue>
    #include<set>
    #include<map>
    #define INF 0x3f3f3f3f
    #define MM(x) memset(x,0,sizeof(x))
    using namespace std;
    typedef long long LL;
    const int N=300010;
    struct info
    {
    	int p;
    	int x;
    	int y;
    	int flag;
    };
    info pre[N];
    int ran[N];
    void init()
    {
    	for (int i=0; i<N; i++)
    	{
    		ran[i]=1;
    		pre[i].p=i;
    	}
    }
    int find(int n)
    {
    	if(n!=pre[n].p)
    		return pre[n].p=find(pre[n].p);
    	return pre[n].p;
    }
    void joint(int a,int b)
    {
    	int fa=find(a),fb=find(b);
    	if(fa!=fb)
    	{
    		if(ran[fa]>ran[fb])
    		{
    			ran[fa]+=ran[fb];
    			pre[fb].p=fa;
    		}
    		else
    		{
    			ran[fb]+=ran[fa];
    			pre[fa].p=fb;
    		}
    	}
    }
    bool dx(const info &a,const info &b,const int &d)
    {
    	return (a.x-b.x)*(a.x-b.x)+(a.y-b.y)*(a.y-b.y)<=d*d;
    }
    int main(void)
    {
    	int n,dis,i,a,b,one;
    	char s[5]={0};
    	init();
    	scanf("%d%d",&n,&dis);
    	for (i=1; i<=n; i++)
    		scanf("%d%d",&pre[i].x,&pre[i].y);
    	while (~scanf("%s",s))
    	{
    		if(s[0]=='O')
    		{
    			scanf("%d",&one);
    			pre[one].flag=1;
    			for (i=1; i<=n; i++)
    			{
    				if(pre[i].flag==1&&dx(pre[i],pre[one],dis))
    					joint(pre[i].p,pre[one].p);
    			}
    		}
    		else if(s[0]=='S')
    		{
    			scanf("%d%d",&a,&b);
    			int fa=find(a),fb=find(b);
    			if(fa==fb)
    				puts("SUCCESS");
    			else
    				puts("FAIL");
    		}
    	}
    	return 0;
    }
  • 相关阅读:
    linux的一些命令
    Java中小数精确计算
    java中基本数据类型和包装类自动装箱和拆箱
    Python学习day14(内置函数二,匿名函数)
    Python学习day13(内置函数一)
    Python学习day12(生成器,列表/生成器推导式)
    Python学习day11(函数名本质,闭包及迭代器)
    Python学习day10(函数名称空间及嵌套)
    Python学习day9(函数初识)
    Python学习day8(文件操作)
  • 原文地址:https://www.cnblogs.com/Blackops/p/5766347.html
Copyright © 2011-2022 走看看