zoukankan      html  css  js  c++  java
  • HDU 6165 FFF at Valentine(Tarjan缩点+拓扑排序)

    FFF at Valentine

    Time Limit: 6000/3000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
    Total Submission(s): 575    Accepted Submission(s): 281

    Problem Description

    At Valentine's eve, Shylock and Lucar were enjoying their time as any other couples. Suddenly, LSH, Boss of FFF Group caught both of them, and locked them into two separate cells of the jail randomly. But as the saying goes: There is always a way out , the lovers made a bet with LSH: if either of them can reach the cell of the other one, then LSH has to let them go.
    The jail is formed of several cells and each cell has some special portals connect to a specific cell. One can be transported to the connected cell by the portal, but be transported back is impossible. There will not be a portal connecting a cell and itself, and since the cost of a portal is pretty expensive, LSH would not tolerate the fact that two portals connect exactly the same two cells.
    As an enthusiastic person of the FFF group, YOU are quit curious about whether the lovers can survive or not. So you get a map of the jail and decide to figure it out.


     
    Input

    ∙Input starts with an integer T (T≤120), denoting the number of test cases.
    ∙For each case,
    First line is two number n and m, the total number of cells and portals in the jail.(2≤n≤1000,m≤6000)
    Then next m lines each contains two integer u and v, which indicates a portal from u to v.


     
    Output

    If the couple can survive, print “I love you my love and our love save us!”
    Otherwise, print “Light my fire!”


     
    Sample Input
    3
    5 5
    1 2
    2 3
    2 4
    3 5
    4 5
     
    3 3
    1 2
    2 3
    3 1
     
    5 5
    1 2
    2 3
    3 1
    3 4
    4 5
     
    Sample Output
    Light my fire!
    I love you my love and our love save us!
    I love you my love and our love save us!

    题目链接:HDU 6165

    似乎比较模版的一道题目,一开始以为是一旦某个缩点后的点的出度超过2就不行了,实际上是可以的,比如1->2、2->3、1->3,这样是三个连通分量且1的出度为2,但是任意取两个点$a,b$还是可以从$a$到达$b$或者$b$到达$a$的,因此更进一步应该是考虑拓扑序上是否同时存在两个可行的点,如果存在说明可以走分岔路这样一来至少分岔路上的两个点就是无法到达的

    代码:

    #include <stdio.h>
    #include <algorithm>
    #include <cstdlib>
    #include <cstring>
    #include <bitset>
    #include <string>
    #include <stack>
    #include <cmath>
    #include <queue>
    #include <set>
    #include <map>
    using namespace std;
    #define INF 0x3f3f3f3f
    #define LC(x) (x<<1)
    #define RC(x) ((x<<1)+1)
    #define MID(x,y) ((x+y)>>1)
    #define fin(name) freopen(name,"r",stdin)
    #define fout(name) freopen(name,"w",stdout)
    #define CLR(arr,val) memset(arr,val,sizeof(arr))
    #define FAST_IO ios::sync_with_stdio(false);cin.tie(0);
    typedef pair<int, int> pii;
    typedef long long LL;
    const double PI = acos(-1.0);
    const int N = 10010;
    const int M = 60010;
    struct edge
    {
        int to, nxt;
    } E[M], e[M];
    int head[N], tot;
    int dfn[N], low[N], st[N], ins[N], scc, in[N], belong[N], ts, top;
    int n, m;
    int H[N], Tot;
    
    void init()
    {
        CLR(head, -1);
        tot = 0;
        CLR(dfn, 0);
        CLR(low, 0);
        CLR(ins, 0);
        scc = 0;
        CLR(in, 0);
        ts = top = 0;
        CLR(H, -1);
        Tot = 0;
    }
    inline void add(int s, int t)
    {
        E[tot].to = t;
        E[tot].nxt = head[s];
        head[s] = tot++;
    }
    inline void Add(int s, int t)
    {
        e[Tot].to = t;
        e[Tot].nxt = H[s];
        H[s] = Tot++;
    }
    void Tarjan(int u)
    {
        dfn[u] = low[u] = ++ts;
        ins[u] = 1;
        st[top++] = u;
        int v;
        for (int i = head[u]; ~i; i = E[i].nxt)
        {
            v = E[i].to;
            if (!dfn[v])
            {
                Tarjan(v);
                low[u] = min(low[u], low[v]);
            }
            else if (ins[v])
                low[u] = min(low[u], dfn[v]);
        }
        if (low[u] == dfn[u])
        {
            ++scc;
            do
            {
                v = st[--top];
                ins[v] = 0;
                belong[v] = scc;
            } while (u != v);
        }
    }
    int solve()
    {
        queue<int>Q;
        int i, j;
        for (i = 1; i <= n; ++i)
            if (!dfn[i])
                Tarjan(i);
        for (i = 1; i <= n; ++i)
        {
            for (j = head[i]; ~j; j = E[j].nxt)
            {
                int v = E[j].to;
                if (belong[v] == belong[i])
                    continue;
                ++in[belong[v]];
                Add(belong[i], belong[v]);
            }
        }
        for (i = 1; i <= scc; ++i)
            if (!in[i])
                Q.push(i);
        while (!Q.empty())
        {
            if (Q.size() >= 2)
                return 0;
            int u = Q.front();
            Q.pop();
            for (int i = H[u]; ~i; i = e[i].nxt)
            {
                int v = e[i].to;
                if (--in[v] == 0)
                    Q.push(v);
            }
        }
        return 1;
    }
    int main(void)
    {
        int T, a, b;
        scanf("%d", &T);
        while (T--)
        {
            init();
            scanf("%d%d", &n, &m);
            while (m--)
            {
                scanf("%d%d", &a, &b);
                add(a, b);
            }
            solve() ? puts("I love you my love and our love save us!") : puts("Light my fire!");
        }
        return 0;
    }
  • 相关阅读:
    数学之路-python计算实战(1)-ubuntu安装pypy
    myeclipse中Servlet出错
    从IBM的计划中分析出中国重新相当然的错误选择吗
    辛星浅谈mysql中的数据碎片以及引擎为MyISAM下的操作
    微信前端js sdk以外的开发
    Hadoop生态系统学习路线
    还原对于server失败 备份集中的数据库备份与现有数据库不同
    hdu 4549 M斐波那契数列(矩阵高速幂,高速幂降幂)
    POJ 题目3667 Hotel(线段树,区间更新查询,求连续区间)
    阿里上市:盘点马云这些年
  • 原文地址:https://www.cnblogs.com/Blackops/p/7417569.html
Copyright © 2011-2022 走看看