zoukankan      html  css  js  c++  java
  • PAT Waiting in Line[转载]

    //转自:https://blog.csdn.net/apie_czx/article/details/45537627

    1014 Waiting in Line (30)(30 分)
    Suppose a bank has N windows open for service. There is a yellow line in front of the windows which devides the waiting area into two parts. The rules for the customers to wait in line are:

    The space inside the yellow line in front of each window is enough to contain a line with M customers. Hence when all the N lines are full, all the customers after (and including) the (NM+1)st one will have to wait in a line behind the yellow line.
    Each customer will choose the shortest line to wait in when crossing the yellow line. If there are two or more lines with the same length, the customer will always choose the window with the smallest number.
    Customer[i] will take T[i] minutes to have his/her transaction processed.
    The first N customers are assumed to be served at 8:00am.
    Now given the processing time of each customer, you are supposed to tell the exact time at which a customer has his/her business done.

    For example, suppose that a bank has 2 windows and each window may have 2 customers waiting inside the yellow line. There are 5 customers waiting with transactions taking 1, 2, 6, 4 and 3 minutes, respectively. At 08:00 in the morning, customer~1~ is served at window~1~ while customer~2~ is served at window~2~. Customer~3~ will wait in front of window~1~ and customer~4~ will wait in front of window~2~. Customer~5~ will wait behind the yellow line.

    At 08:01, customer~1~ is done and customer~5~ enters the line in front of window~1~ since that line seems shorter now. Customer~2~ will leave at 08:02, customer~4~ at 08:06, customer~3~ at 08:07, and finally customer~5~ at 08:10.

    Input

    Each input file contains one test case. Each case starts with a line containing 4 positive integers: N (<=20, number of windows), M (<=10, the maximum capacity of each line inside the yellow line), K (<=1000, number of customers), and Q (<=1000, number of customer queries).

    The next line contains K positive integers, which are the processing time of the K customers.

    The last line contains Q positive integers, which represent the customers who are asking about the time they can have their transactions done. The customers are numbered from 1 to K.

    Output

    For each of the Q customers, print in one line the time at which his/her transaction is finished, in the format HH:MM where HH is in [08, 17] and MM is in [00, 59]. Note that since the bank is closed everyday after 17:00, for those customers who cannot be served before 17:00, you must output "Sorry" instead.

    Sample Input

    2 2 7 5
    1 2 6 4 3 534 2
    3 4 5 6 7
    Sample Output

    08:07
    08:06
    08:10
    17:00
    Sorry

    //这个输入还比较复杂。
    窗口数 黄线内最多可容纳人数 消费者总人数 查询次数
    每个消费者业务办理时间数
    要查询的消费者编号

     //emmm,每太见过这样的题,所以我应该做不出来了,就把大佬的代码贴过来了,

    #include<stdio.h>
    #include<queue>
    using namespace std;
    int serve_time[1001];
    int ans[1001];
    queue<int> Q[21];
    int main(void)
    {
        int w,cap,cus,k;//分别记录窗口数量、窗口最大人数、顾客数量和查询数量
        int i,j;
        while(scanf("%d%d%d%d",&w,&cap,&cus,&k) != EOF)
        {
            for(i = 1; i <= cus; i ++)
            {
                scanf("%d",&serve_time[i]);
            }
            for(i = 0; i < w; i ++)
            {
                if(Q[i].empty() == false)Q[i].pop();//对每个窗口都清空
            }
    
            int sum = 0;
            int count = 1;
            for(int ti = 0; ti < 540; ti = ti + 1) //以时间来作为循环,这个很关键
            {//还真的是以时间作为循环,我还以为会超时什么的。
                for(i = 0; i < w; i ++)//这层循环是说一共有多少个窗口数
                {
                    for(j = 0; j < Q[i].size(); j ++)//对每个窗口单独看
                    {
                        if(ti == ans[Q[i].front()]) //如果当前队伍的人服务结束了
                        {
                            Q[i].pop();
                            sum --;
    
    
                            if(!Q[i].empty()) //并且计算当前队伍下一个人的结束时间
                            {
                                int tmp = Q[i].front();
                                ans[tmp] = ti + serve_time[tmp];//结束时间为当前时间+顾客的服务时间
                            }
                        }
                    }
                }
    
                while(sum < w * cap && count <= cus)//比如说一开始的时候,sum=0,那么就相当于初始情况
                {
                    int min = 0;
                    for(i = 0; i < w; i++)
                    {
                        if(Q[min].size() > Q[i].size())
                        {
                            min = i;
                        }//找到人最少的那个队伍
                        if(Q[min].size() == 0)  ans[count] = ti + serve_time[count];
                        //如果队伍没人则直接开始服务,并且计算结束时间
                        if(Q[min].size() < cap && count <= cus)//而且当前的总人数不超
                        {//这里也不是while循环,知识针对一个来说的。
                            Q[min].push(count);//否则把让下一个顾客进队
                            count ++;
                            sum ++;//sum这里表示的是队列内的总人数。
                        }
                    }
                }
            }
    
            for(i = 0; i < k; i ++)
            {
                int query;
                scanf("%d",&query);
                if(ans[query] == 0)puts("Sorry");//值为0说明没有被开始服务,只能Sorry
                else
                {
                    int hour,min;
                    hour = 8 + ans[query] / 60;//这里操作真厉害
                    min = ans[query] % 60;
                    printf("%02d:%02d\n",hour,min);//把时间转换为标准格式并输出
                    //原来还可以在这里转换成时间,我还想每次结束都转换呢map<int,string>这样确实不太好。
                }
            }
        }
        return 0;
    }

    //对时间进行循环,模拟仿真,再对队列进行循环。

    //我还是觉得很难。

  • 相关阅读:
    Scite 编辑器及其相关项目介绍
    cmake 常用指令入门指南
    C++中的POD类型
    引用折叠、万能引用和完美转发那些事
    c++的对象初始化
    C++类对象的内存布局
    effective C++ 读书精华笔记提取
    c/c++的const说明符——深入挖掘
    gdb调试器—常用知识(一)
    g++/gcc编译器——常用知识(一)
  • 原文地址:https://www.cnblogs.com/BlueBlueSea/p/9342700.html
Copyright © 2011-2022 走看看