zoukankan      html  css  js  c++  java
  • PAT 1034 Head of a Gang[难][dfs]

    1034 Head of a Gang (30)(30 分)

    One way that the police finds the head of a gang is to check people's phone calls. If there is a phone call between A and B, we say that A and B is related. The weight of a relation is defined to be the total time length of all the phone calls made between the two persons. A "Gang" is a cluster of more than 2 persons who are related to each other with total relation weight being greater than a given threshold K. In each gang, the one with maximum total weight is the head. Now given a list of phone calls, you are supposed to find the gangs and the heads.

    Input Specification:

    Each input file contains one test case. For each case, the first line contains two positive numbers N and K (both less than or equal to 1000), the number of phone calls and the weight threshold, respectively. Then N lines follow, each in the following format:

    Name1 Name2 Time

    where Name1 and Name2 are the names of people at the two ends of the call, and Time is the length of the call. A name is a string of three capital letters chosen from A-Z. A time length is a positive integer which is no more than 1000 minutes.

    Output Specification:

    For each test case, first print in a line the total number of gangs. Then for each gang, print in a line the name of the head and the total number of the members. It is guaranteed that the head is unique for each gang. The output must be sorted according to the alphabetical order of the names of the heads.

    Sample Input 1:

    8 59
    AAA BBB 10
    BBB AAA 20
    AAA CCC 40
    DDD EEE 5
    EEE DDD 70
    FFF GGG 30
    GGG HHH 20
    HHH FFF 10

    Sample Output 1:

    2
    AAA 3
    GGG 3

    Sample Input 2:

    8 70
    AAA BBB 10
    BBB AAA 20
    AAA CCC 40
    DDD EEE 5
    EEE DDD 70
    FFF GGG 30
    GGG HHH 20
    HHH FFF 10

    Sample Output 2:

    0

     题目大意:给出一个阈值k,一个帮派的定义是人数大于2,必须是3人或者3人以上,并且总的通话时长要>k,=k不可以,满足这两个条件,就可以被称为一个帮派,在一个帮派内部,需要找出累计通话时长最多的人,那个人就是头,并且输出帮派内总人数。

     //和普通的不一样的就是,现在图的下标不是用数字来表示了,而是用字母。

    //虽然说可以用并查集,但是在一个数组里也不好遍历。set也不好用,除非结构体里设置很多属性,但是这样维护起来不好维护。好麻烦啊这道题。看似简单。

    大佬代码: 

    #include <iostream>
    #include <map>
    using namespace std;
    map<string, int> stringToInt;
    map<int, string> intToString;
    map<string, int> ans;
    int idNumber = 1, k;
    int stoifunc(string s) {
        if(stringToInt[s] == 0) {//如果不存在,那么就加入map里
            stringToInt[s] = idNumber;
            intToString[idNumber] = s;//两方都存上。
            return idNumber++;
        } else {
            return stringToInt[s];
        }
    }
    int G[2010][2010], weight[2010];
    bool vis[2010];
    void dfs(int u, int &head, int &numMember, int &totalweight) {//使用引用传值,并且可以得到返回值。
        vis[u] = true;
        numMember++;
        if(weight[u] > weight[head])
            head = u;
        for(int v = 1; v < idNumber; v++) {
            if(G[u][v] > 0) {
                totalweight += G[u][v];
                G[u][v] = G[v][u] = 0;//赋值为0,避免多次计算。
                if(vis[v] == false)
                    dfs(v, head, numMember, totalweight);//totalWeight是只计算边。
            }
        }
    }
    
    void dfsTrave() {
        for(int i = 1; i < idNumber; i++) {//如果有多个连通分量
            if(vis[i] == false) {//被访问过的都被标记为了true
                int head = i, numMember = 0, totalweight = 0;
                dfs(i, head, numMember, totalweight);//这里为什么传了两个呢?因为第一个i只是表示从它开始遍历,而第二个head才是真正的头。
                if(numMember > 2 && totalweight > k)
                    ans[intToString[head]] = numMember;
            }
        }
    }
    int main() {
        int n, w;
        cin >> n >> k;
        string s1, s2;
        for(int i = 0; i < n; i++) {
            cin >> s1 >> s2 >> w;
            int id1 = stoifunc(s1);
            int id2 = stoifunc(s2);
            weight[id1] += w;//这里记录上每个点的总通话时长。
            weight[id2] += w;
            G[id1][id2] += w;//两点之间也加上,并且是不分单向双向的。
            G[id2][id1] += w;
        }
        dfsTrave();
        cout << ans.size() << endl;
        for(auto it = ans.begin(); it != ans.end(); it++)
            cout << it->first << " " << it->second << endl;
        return 0;
    }

    //简直不要太厉害了。

    1.没有使用结构体,我想的是使用结构体,但是那样也十分不方便。

    2.怎样区分帮派呢?我一开始想的就很乱,使用dfs。计数总共有多少人,并且点有点的权重,边之间也有,它们是不混淆的,并且没有使用并查集,对总体进行一个循环,并且每次从这个点出发去访问后就会标记该点,并且判断条件是边之间>0,那么一次循环下来,一个帮派内的就会被遍历到。

    3.使用引用传值,https://blog.csdn.net/zx3517288/article/details/53363798/

    这篇文章讲传值传地址,十分好。

    4.关键是使用邻接矩阵来存储边了,但是我都没有想到。

  • 相关阅读:
    PyCharm 3.4注册码
    监控Oracle索引是否被启用
    Oracle execute plan 原理分析与实例分享(转)
    6 个重构方法可帮你提升代码质量(转载)
    跟我一起学Oracle 11g【2】----用户管理(转载)
    notecore设置linux/Unix系统文件权限
    Unicode特殊字符的坑
    net多线程
    走过的HttpClient坑
    Postgre备份还原
  • 原文地址:https://www.cnblogs.com/BlueBlueSea/p/9457604.html
Copyright © 2011-2022 走看看