zoukankan      html  css  js  c++  java
  • PAT 1081 Rational Sum[分子求和][比较]

    1081 Rational Sum (20 分)

    Given N rational numbers in the form numerator/denominator, you are supposed to calculate their sum.

    Input Specification:

    Each input file contains one test case. Each case starts with a positive integer N (100), followed in the next line N rational numbers a1/b1 a2/b2 ... where all the numerators and denominators are in the range of long int. If there is a negative number, then the sign must appear in front of the numerator.

    Output Specification:

    For each test case, output the sum in the simplest form integer numerator/denominator where integer is the integer part of the sum, numerator denominator, and the numerator and the denominator have no common factor. You must output only the fractional part if the integer part is 0.

    Sample Input 1:

    5
    2/5 4/15 1/30 -2/60 8/3
    

    Sample Output 1:

    3 1/3
    

    Sample Input 2:

    2
    4/3 2/3
    

    Sample Output 2:

    2
    

    Sample Input 3:

    3
    1/3 -1/6 1/8
    

    Sample Output 3:

    7/24
    (20 分)

    Given N rational numbers in the form numerator/denominator, you are supposed to calculate their sum.

    Input Specification:

    Each input file contains one test case. Each case starts with a positive integer N (100), followed in the next line N rational numbers a1/b1 a2/b2 ... where all the numerators and denominators are in the range of long int. If there is a negative number, then the sign must appear in front of the numerator.

    Output Specification:

    For each test case, output the sum in the simplest form integer numerator/denominator where integer is the integer part of the sum, numerator denominator, and the numerator and the denominator have no common factor. You must output only the fractional part if the integer part is 0.

    Sample Input 1:

    5
    2/5 4/15 1/30 -2/60 8/3
    

    Sample Output 1:

    3 1/3
    

    Sample Input 2:

    2
    4/3 2/3
    

    Sample Output 2:

    2
    

    Sample Input 3:

    3
    1/3 -1/6 1/8
    

    Sample Output 3:

    7/24

     题目大意:给出几个分数求和。

    //又是分数求和的题目,细节会很多啊。

    #include <iostream>
    #include <map>
    using namespace std;
    
    int n;
    int nums[100];
    
    int getSum(int s,int f){
        if(f>=n){//如果已经到了尽头,那么就对s约分并且输出
            //还是需要先根据分母找出所有的最小公倍数呢?
            //一点也不会。写不下去。
        }
    }
    
    int main() {
    
        cin>>n;
        for(int i=0;i<n;i++){
            cin>>nums[i];
        }
        cout<<getSum(0,1);
    
        return 0;
    }
    View Code

    代码转自:https://www.liuchuo.net/archives/2108

    #include <iostream>
    #include <cstdlib>
    using namespace std;
    long long gcd(long long a, long long b) {return b == 0 ? abs(a) : gcd(b, a % b);}
    int main() {
        long long n, a, b, suma = 0, sumb = 1, gcdvalue;//注意数据类型的定义。
        scanf("%lld", &n);
        for(int i = 0; i < n; i++) {
            scanf("%lld/%lld", &a, &b);
            gcdvalue = gcd(a, b);//找到最大公约数进行约分。
            a = a / gcdvalue;
            b = b / gcdvalue;
            suma = a * sumb + suma * b;//分子
            sumb = b * sumb;//计算分母
            gcdvalue = gcd(suma, sumb);
            sumb = sumb / gcdvalue;//再约分。
            suma = suma / gcdvalue;
        }
        long long integer = suma / sumb;
        suma = suma - (sumb * integer);//计算余下的分子。
        if(integer != 0) {
            printf("%lld", integer);
            if(suma != 0) printf(" ");//如果余下的分子不为0.
        }
        if(suma != 0)
            printf("%lld/%lld", suma, sumb);
        if(integer == 0 && suma == 0)
            printf("0");
        return 0;
    }

    //学习了,需要经常复习吧,要不还是不会。

  • 相关阅读:
    java值类型和引用类型
    0513作业
    随机四位验证码
    1-36随机生成6个不重复的数
    java随机数
    0509作业
    作业0508
    字符集
    eclipse快捷键
    数据类型 转换
  • 原文地址:https://www.cnblogs.com/BlueBlueSea/p/9764389.html
Copyright © 2011-2022 走看看