zoukankan      html  css  js  c++  java
  • PAT 1041 Be Unique[简单]

    1041 Be Unique (20 分)

    Being unique is so important to people on Mars that even their lottery is designed in a unique way. The rule of winning is simple: one bets on a number chosen from [1,104​​]. The first one who bets on a unique number wins. For example, if there are 7 people betting on { 5 31 5 88 67 88 17 }, then the second one who bets on 31 wins.

    Input Specification:

    Each input file contains one test case. Each case contains a line which begins with a positive integer N (105​​) and then followed by N bets. The numbers are separated by a space.

    Output Specification:

    For each test case, print the winning number in a line. If there is no winner, print None instead.

    Sample Input 1:

    7 5 31 5 88 67 88 17
    

    Sample Output 1:

    31
    

    Sample Input 2:

    5 888 666 666 888 888
    

    Sample Output 2:

    None

     题目大意:给出n个数,判断其中不重复出现的第一个数,如果均是重复出现,那么就输出None.

    //还是比较简单的。AC了:

    #include <iostream>
    #include <vector>
    #include<unordered_map>
    using namespace std;
    
    int main()
    {
        int n,ans=-1;
        cin>>n;
        unordered_map<int,int> mp;
        vector<int> vt;
        int key;
        for(int i=0;i<n;i++){
            cin>>key;
            vt.push_back(key);
            if(mp[key]==0)
                mp[key]=-1;
            else
                mp[key]=1;
        }
        for(int i=0;i<vt.size();i++){
            if(mp[vt[i]]==-1){
                ans=vt[i];break;
            }
        }
        if(ans==-1)
            cout<<"None";
        else
            cout<<ans;
    
       return(0);
    }

    1.其实可以不使用unorder_map的,它并不是按输入顺序排序,而是随机的吧,可以使用map

    2.既然要记录顺序,那么就使用vector来存储原来的输入顺序这个是需要的。 

  • 相关阅读:
    [Lydsy1706月赛]大根堆
    某考试 T1 Function
    [SHOI2016] 随机序列
    某考试 T1 至危警告
    某考试 T2 yja
    bzoj1880 [Sdoi2009]Elaxia的路线
    bzoj1804 [Ioi2007]Flood 洪水
    bzoj4546 codechef XRQRS
    bzoj4547 小奇的集合
    bzoj1443 [JSOI2009]游戏Game
  • 原文地址:https://www.cnblogs.com/BlueBlueSea/p/9953187.html
Copyright © 2011-2022 走看看