zoukankan      html  css  js  c++  java
  • 2017 Multi-University Training Contest

    Regular polygon

    Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
    Total Submission(s): 177    Accepted Submission(s): 74


    Problem Description
    On a two-dimensional plane, give you n integer points. Your task is to figure out how many different regular polygon these points can make.
     
    Input
    The input file consists of several test cases. Each case the first line is a numbers N (N <= 500). The next N lines ,each line contain two number Xi and Yi(-100 <= xi,yi <= 100), means the points’ position.(the data assures no two points share the same position.)
     
    Output
    For each case, output a number means how many different regular polygon these points can make.
     
    Sample Input
    4 0 0 0 1 1 0 1 1 6 0 0 0 1 1 0 1 1 2 0 2 1
     
    Sample Output
    1 2
     
    Source
     
    最弱的一题,不过这个正多边形必然是正方形有点骚,不好想啊
    #include <bits/stdc++.h>
    using namespace std;
    int main() {
        int x[505],y[505];
        int n;
        while(cin>>n) {
            set<pair<int,int> >S;
            for(int i=0; i<n; i++) {
                cin>>x[i]>>y[i];
                S.insert(make_pair(x[i],y[i]));
            }
            int cnt=0;
            for(int i=0; i<n; i++)
                for(int j=0; j<i; j++) {
                    int mx=x[i]+x[j],dx=max(x[i],x[j])-min(x[i],x[j]);
                    int my=y[i]+y[j],dy=max(y[i],y[j])-min(y[i],y[j]);
                    if ((mx+dy)&1||(my+dx)&1) continue;
                    int sg=((x[i]-x[j])*(y[i]-y[j])<0)?1:-1;
                    if (S.count(make_pair((mx+dy)/2,(my+sg*dx)/2))&&S.count(make_pair((mx-dy)/2,(my-sg*dx)/2)))
                        cnt++;
    
                }
            cout<<cnt/2<<endl;
        }
        return 0;
    }
     
    大佬您太强了,还请多多指教哎
  • 相关阅读:
    TCP/UDP常见端口参考
    HTTP状态码对照表 HTTP response codes
    HTTP请求方法对照表
    服务器返回的各种HTTP状态码介绍
    HTTP响应头和请求头信息对照表
    简析TCP的三次握手与四次分手
    什么是JDK
    jmeter使用IP欺骗压力测试
    jmeter制造安全证书
    Python 变量作用域
  • 原文地址:https://www.cnblogs.com/BobHuang/p/7246539.html
Copyright © 2011-2022 走看看