zoukankan      html  css  js  c++  java
  • [POJ1007] DNA Sorting

    DNA Sorting
    Time Limit: 1000MS   Memory Limit: 10000K
    Total Submissions: 108298   Accepted: 43370

    Description

    One measure of ``unsortedness'' in a sequence is the number of pairs of entries that are out of order with respect to each other. For instance, in the letter sequence ``DAABEC'', this measure is 5, since D is greater than four letters to its right and E is greater than one letter to its right. This measure is called the number of inversions in the sequence. The sequence ``AACEDGG'' has only one inversion (E and D)---it is nearly sorted---while the sequence ``ZWQM'' has 6 inversions (it is as unsorted as can be---exactly the reverse of sorted).

    You are responsible for cataloguing a sequence of DNA strings (sequences containing only the four letters A, C, G, and T). However, you want to catalog them, not in alphabetical order, but rather in order of ``sortedness'', from ``most sorted'' to ``least sorted''. All the strings are of the same length.

    Input

    The first line contains two integers: a positive integer n (0 < n <= 50) giving the length of the strings; and a positive integer m (0 < m <= 100) giving the number of strings. These are followed by m lines, each containing a string of length n.

    Output

    Output the list of input strings, arranged from ``most sorted'' to ``least sorted''. Since two strings can be equally sorted, then output them according to the orginal order.

    Sample Input

    10 6
    AACATGAAGG
    TTTTGGCCAA
    TTTGGCCAAA
    GATCAGATTT
    CCCGGGGGGA
    ATCGATGCAT

    Sample Output

    CCCGGGGGGA
    AACATGAAGG
    GATCAGATTT
    ATCGATGCAT
    TTTTGGCCAA
    TTTGGCCAAA



    水题~
    #include <iostream>
    #include <cstdio>
    #include <algorithm>
    using namespace std;
    
    struct date
    {
        string st;
        int num;
    }a[105];
    int n, m;
    bool cmp(date x, date y){return x.num < y.num;}
    signed main()
    {
        cin >> n >> m;
        for (register int i = 1 ; i <= m ; i ++)
        {
            cin >> a[i].st;
            for (register int j = 0 ; j < n ; j ++)
            {
                for (register int k = j + 1 ; k < n ; k ++)
                {
                    if (a[i].st[j] > a[i].st[k]) a[i].num ++;
                }
            }
        }
        sort (a + 1, a + 1 + m , cmp);
        for (register int i = 1 ; i <= m ; i ++)
            cout<<a[i].st<<endl;
        return 0;
    }
  • 相关阅读:
    Linux编程之UDP SOCKET全攻略
    Java8 flatMap的sample
    swagger bug
    bash中的pasue
    树、二叉树、满二叉树、完全二叉树概念分清
    复习一下高中数学
    SpringBoot Junit Maven JaCoCo
    事务传播和隔离
    springboot swagger2 泛型踩坑记
    Code::Blocks debug程序
  • 原文地址:https://www.cnblogs.com/BriMon/p/9291587.html
Copyright © 2011-2022 走看看