zoukankan      html  css  js  c++  java
  • POJ 2418 Hardwood Species

                                                     Hardwood Species
    Time Limit: 10000MS   Memory Limit: 65536K
    Total Submissions: 16056   Accepted: 6418

    Description

    Hardwoods are the botanical group of trees that have broad leaves, produce a fruit or nut, and generally go dormant in the winter. 
    America's temperate climates produce forests with hundreds of hardwood species -- trees that share certain biological characteristics. Although oak, maple and cherry all are types of hardwood trees, for example, they are different species. Together, all the hardwood species represent 40 percent of the trees in the United States. 

    On the other hand, softwoods, or conifers, from the Latin word meaning "cone-bearing," have needles. Widely available US softwoods include cedar, fir, hemlock, pine, redwood, spruce and cypress. In a home, the softwoods are used primarily as structural lumber such as 2x4s and 2x6s, with some limited decorative applications. 

    Using satellite imaging technology, the Department of Natural Resources has compiled an inventory of every tree standing on a particular day. You are to compute the total fraction of the tree population represented by each species.

    Input

    Input to your program consists of a list of the species of every tree observed by the satellite; one tree per line. No species name exceeds 30 characters. There are no more than 10,000 species and no more than 1,000,000 trees.

    Output

    Print the name of each species represented in the population, in alphabetical order, followed by the percentage of the population it represents, to 4 decimal places.

    Sample Input

    Red Alder
    Ash
    Aspen
    Basswood
    Ash
    Beech
    Yellow Birch
    Ash
    Cherry
    Cottonwood
    Ash
    Cypress
    Red Elm
    Gum
    Hackberry
    White Oak
    Hickory
    Pecan
    Hard Maple
    White Oak
    Soft Maple
    Red Oak
    Red Oak
    White Oak
    Poplan
    Sassafras
    Sycamore
    Black Walnut
    Willow

    Sample Output

    Ash 13.7931
    Aspen 3.4483
    Basswood 3.4483
    Beech 3.4483
    Black Walnut 3.4483
    Cherry 3.4483
    Cottonwood 3.4483
    Cypress 3.4483
    Gum 3.4483
    Hackberry 3.4483
    Hard Maple 3.4483
    Hickory 3.4483
    Pecan 3.4483
    Poplan 3.4483
    Red Alder 3.4483
    Red Elm 3.4483
    Red Oak 6.8966
    Sassafras 3.4483
    Soft Maple 3.4483
    Sycamore 3.4483
    White Oak 10.3448
    Willow 3.4483
    Yellow Birch 3.4483

    Hint

    This problem has huge input, use scanf instead of cin to avoid time limit exceeded.

    Source


    map水。。。。


    #include <iostream>
    #include <cstdio>
    #include <cstring>
    #include <string>
    #include <map>

    using namespace std;

    int main()
    {
        char name[40];
        map<string,int> mSI;
        while(gets(name))
        {
            string s(name);
            if(mSI.count(s))
            {
                mSI[s]++;
            }
            else
            {
                mSI.insert( pair<string,int>(s,1) );
            }
        }

        map<string,int>::iterator beg=mSI.begin(),end=mSI.end(),i=beg;
        double sum=0;
        for(;i!=end;i++)
        {
            sum+=(*i).second;
        }
        for(i=beg;i!=end;i++)
        {
            printf("%s %.4lf ",(i->first).c_str(),(i->second)*100/sum);
        }

        return 0;
    }

    * This source code was highlighted by YcdoiT. ( style: Codeblocks )

  • 相关阅读:
    LeetCode----->dp系列
    重读STL源码剖析:vector
    重读深度探索C++对象模型:构造
    LeetCode4:寻找两个有序数组的中位数
    部署测试环境(ubuntu+mysql+tomcat)
    开发环境配置(netbeans+ant迁移到eclipse+maven)
    笔记《Java程序性能优化 让你的Java程序更快、更稳定》 第二章 设计调优
    企业高并发的成熟解决方案(一)video(笔记&知识点)
    猎豹使用AI RoboForm填表
    FreeMarker笔记 第四章 其它
  • 原文地址:https://www.cnblogs.com/CKboss/p/3314036.html
Copyright © 2011-2022 走看看