zoukankan      html  css  js  c++  java
  • HDOJ 1520 Anniversary party


    树形DP。。。。在树上做DP。。。。不应该是猴子干的事吗?HDOJ 1520 Anniversary party - qhn999 - 码代码的猿猿 

    Anniversary party

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 3563    Accepted Submission(s): 1648


    Problem Description
    There is going to be a party to celebrate the 80-th Anniversary of the Ural State University. The University has a hierarchical structure of employees. It means that the supervisor relation forms a tree rooted at the rector V. E. Tretyakov. In order to make the party funny for every one, the rector does not want both an employee and his or her immediate supervisor to be present. The personnel office has evaluated conviviality of each employee, so everyone has some number (rating) attached to him or her. Your task is to make a list of guests with the maximal possible sum of guests' conviviality ratings.
     

    Input
    Employees are numbered from 1 to N. A first line of input contains a number N. 1 <= N <= 6 000. Each of the subsequent N lines contains the conviviality rating of the corresponding employee. Conviviality rating is an integer number in a range from -128 to 127. After that go T lines that describe a supervisor relation tree. Each line of the tree specification has the form: 
    L K 
    It means that the K-th employee is an immediate supervisor of the L-th employee. Input is ended with the line 
    0 0
     

    Output
    Output should contain the maximal sum of guests' ratings.
     

    Sample Input
    7
    1
    1
    1
    1
    1
    1
    1
    1 3
    2 3
    6 4
    7 4
    4 5
    3 5
    0 0
     

    Sample Output
    5
     

    Source
     

    Recommend
    linle
     
     

    #include <iostream>
    #include <cstdio>
    #include <cstring>
    #include <vector>

    using namespace std;

    int valu[7000],dp[7000][2],N,L,K;
    bool isson[7000];
    vector<int> g[7000];

    void dfs(int u,int fa)
    {
        //printf("%d--->%d ",u,g.size());
        for(int i=0;i<g.size();i++)
        {
            int v=g;
            if(v==fa) continue;
            dfs(v,u);
        }
        int qu=0,buqu=0;
        if(g.size()==1)
        {
            //printf("...%d ",u);
        }
        for(int i=0;i<g.size();i++)
        {
            int v=g;
            if(v==fa) continue;
            qu=max(qu,qu+dp[v][0]);
            buqu=max(buqu+dp[v][1],max(dp[v][0]+buqu,buqu));
        }
        dp[0]=buqu;
        dp[1]=qu+valu;
    }

    int main()
    {
        while(scanf("%d",&N)!=EOF)
        {
            for(int i=1;i<=N;i++)
            {
                scanf("%d",valu+i);
                g.clear();
            }
            memset(isson,false,sizeof(isson));
            memset(dp,0,sizeof(dp));
            while(scanf("%d%d",&L,&K)!=EOF)
            {
                if(L==0&&K==0break;
                isson[L]=true;
                g[L].push_back(K);
                g[K].push_back(L);
            }
            int root=-1;
            for(int i=1;i<=N;i++)
            {
                if(!isson)
                {
                    root=i; break;
                }
            }
            dfs(root,-1);
            printf("%d ",max(dp[root][1],dp[root][0]));
        }
        return 0;
    }
    * This source code was highlighted by YcdoiT. ( style: Codeblocks )


  • 相关阅读:
    微信开发(5):公众号消息与事件推送处理(转)
    微信开发(4):微信第三方开放平台的搭建(转)
    微信开发(3):微信公众号发现金红包功能开发,利用第三方SDK实现(转)
    微信开发(2):微信js sdk分享朋友圈,朋友,获取config接口注入权限验证(转)
    微信开发(1) :网页授权获取用户的基本信息 实现微信登录(转)
    java实现创建临时文件然后在程序退出时自动删除文件(转)
    Linux定时对日志批量打包Shell脚本及定时任务crontab 详细用法
    httpd2.4出现AH00025: configuration error
    apache启动失败
    软件工程中的反面模式(anti-pattern)
  • 原文地址:https://www.cnblogs.com/CKboss/p/3350823.html
Copyright © 2011-2022 走看看