zoukankan      html  css  js  c++  java
  • HDOJ 2444 The Accomodation of Students

     

    染色判读二分图+Hungary匹配

    The Accomodation of Students

    Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 1705    Accepted Submission(s): 821


    Problem Description
    There are a group of students. Some of them may know each other, while others don't. For example, A and B know each other, B and C know each other. But this may not imply that A and C know each other.

    Now you are given all pairs of students who know each other. Your task is to divide the students into two groups so that any two students in the same group don't know each other.If this goal can be achieved, then arrange them into double rooms. Remember, only paris appearing in the previous given set can live in the same room, which means only known students can live in the same room.

    Calculate the maximum number of pairs that can be arranged into these double rooms.
     

    Input
    For each data set:
    The first line gives two integers, n and m(1<n<=200), indicating there are n students and m pairs of students who know each other. The next m lines give such pairs.

    Proceed to the end of file.

     

    Output
    If these students cannot be divided into two groups, print "No". Otherwise, print the maximum number of pairs that can be arranged in those rooms.
     

    Sample Input
    4 4
    1 2
    1 3
    1 4
    2 3
    6 5
    1 2
    1 3
    1 4
    2 5
    3 6

     

    Sample Output
    No
    3
     

    Source
     

    Recommend
    gaojie
     



    #include <iostream>
    #include <cstring>
    #include <cstdio>
    #include <queue>

    using namespace std;

    typedef struct
    {
        int to,next;
    }Edge;

    Edge E[50000];
    int Adj[50000],Size=0,color[500],n,m,from[500];
    bool use[500];

    void Init()
    {
        Size=0;
        memset(Adj,-1,sizeof(Adj));
    }

    void Add_Edge(int u,int v)
    {
        E[Size].to=v;
        E[Size].next=Adj;
        Adj=Size++;
    }

    bool match(int x)
    {
        for(int i=Adj[x];~i;i=E.next)
        {
            int v=E.to;
            if(!use[v])
            {
                use[v]=true;
                if(from[v]==-1||match(from[v]))
                {
                    from[v]=x;
                    return true;
                }
            }
        }
        return false;
    }

    int hungary()
    {
        int sum=0;
        memset(from,-1,sizeof(from));
        for(int i=1;i<=n;i++)
        {
            if(color==1)
            {
                memset(use,false,sizeof(use));
                sum+=match(i);
            }
        }
        return sum;
    }

    int main()
    {
        while(scanf("%d%d",&n,&m)!=EOF)
        {
            int u,v;
            Init();
            while(m--)
            {
                scanf("%d%d",&u,&v);
                Add_Edge(u,v);
                Add_Edge(v,u);
            }
            memset(color,0,sizeof(color));
            bool flag=true;
    while(true)
    {
            int pos=-1;
            if(flag==falsebreak;
            for(int i=1;i<=n;i++)
            {
                if(Adj==-1continue;
                else if(color!=0continue;
                else
                {
                    pos=i; break;
                }
            }
            if(pos==-1break;
            queue<int> q;
            q.push(pos); color[pos]=1;
            //printf("%d:  ",pos);
            while(!q.empty())
            {
                if(flag==falsebreak;
                int u=q.front(); q.pop();
                for(int i=Adj;~i;i=E.next)
                {
                    int v=E.to;
                    //printf("%d--->%d ",u,v);
                    if(color[v]==0)
                    {
                        color[v]=-color;
                        q.push(v);
                    }
                    else if(color[v]==color)
                    {
                        flag=falsebreak;
                    }
                }
            }
    }
            if(flag==false)
            {
                puts("No");
            }
            else
            {
                printf("%d ",hungary());
            }
        }
        return 0;
    }
    * This source code was highlighted by YcdoiT. ( style: Codeblocks )


  • 相关阅读:
    解决命令行乱码问题(中文乱码)
    Outlook 修改归档文件顶层目录名
    (职员)2015-11-11 星期三 日志
    职员)2015-11-10 星期二 日志
    职员)2015-11-09 星期一 日志
    (职员)2015-11-05 星期四 日志
    (职员)2015-11-04 星期三 日志
    (职员)2015-11-03 星期二 日志
    (职员)2015-11-02 星期一 日志
    (职员)2015-10-31 星期六 周志
  • 原文地址:https://www.cnblogs.com/CKboss/p/3350832.html
Copyright © 2011-2022 走看看