zoukankan      html  css  js  c++  java
  • POJ 3349 Snowflake Snow Snowflakes



    Snowflake Snow Snowflakes
    Time Limit: 4000MSMemory Limit: 65536K
    Total Submissions: 27598Accepted: 7312

    Description

    You may have heard that no two snowflakes are alike. Your task is to write a program to determine whether this is really true. Your program will read information about a collection of snowflakes, and search for a pair that may be identical. Each snowflake has six arms. For each snowflake, your program will be provided with a measurement of the length of each of the six arms. Any pair of snowflakes which have the same lengths of corresponding arms should be flagged by your program as possibly identical.

    Input

    The first line of input will contain a single integer n, 0 < n ≤ 100000, the number of snowflakes to follow. This will be followed by n lines, each describing a snowflake. Each snowflake will be described by a line containing six integers (each integer is at least 0 and less than 10000000), the lengths of the arms of the snow ake. The lengths of the arms will be given in order around the snowflake (either clockwise or counterclockwise), but they may begin with any of the six arms. For example, the same snowflake could be described as 1 2 3 4 5 6 or 4 3 2 1 6 5.

    Output

    If all of the snowflakes are distinct, your program should print the message:
    No two snowflakes are alike.
    If there is a pair of possibly identical snow akes, your program should print the message:
    Twin snowflakes found.

    Sample Input

    2
    1 2 3 4 5 6
    4 3 2 1 6 5

    Sample Output

    Twin snowflakes found.

    Source

    CCC 2007 

    hash函数。。。3750ms。。。险过。。。
    #include <iostream>
    #include <cstdio>
    #include <cstring>
    #include <vector>

    using namespace std;

    struct ST
    {
       int a[6];
    };

    bool cmp(const ST x,const ST y)
    {
        bool flag=true;
        for(int i=0;i<6;i++)
        {
            flag=true;
            for(int j=0;j<6;j++)
            {
                if(x.a[j]!=y.a[(j+i)%6])
                {
                    flag=false;
                    break;
                }
            }
            if(flag) return true;
        }
        for(int i=0;i<6;i++)
        {
            flag=true;
            for(int j=0;j<6;j++)
            {
                if(x.a[5-j]!=y.a[(j+i)%6])
                {
                    flag=false;
                    break;
                }
            }
            if(flag) return true;
        }
        return false;
    }

    int main()
    {
        int n;
        ST A; bool flag=false;
        vector<ST> hash[17569];
        scanf("%d",&n);
        for(int i=0;i<n;i++)
        {
            int sum=0;
            for(int j=0;j<6;j++)
            {
                scanf("%d",&A.a[j]);
                sum+=A.a[j];
            }
            hash[sum%17569].push_back(A);
        }
        for(int i=0;i<17569;i++)
        {
            if(flag) continue;
            int nth=hash.size();
            for(int j=0;j<nth;j++)
            {
                for(int k=j+1;k<nth;k++)
                {
                    if(cmp(hash[j],hash[k]))
                    {
                        puts("Twin snowflakes found.");
                        flag=true;
                        break;
                    }
                }
            }
        }
        if(flag==false)
            puts("No two snowflakes are alike.");
        return 0;
    }
    * This source code was highlighted by YcdoiT. ( style: Codeblocks )

  • 相关阅读:
    [LeetCode] 34. 在排序数组中查找元素的第一个和最后一个位置
    [LeetCode] 32. 最长有效括号
    [LeetCode] 31. 下一个排列
    [LeetCode] 30. 串联所有单词的子串
    [LeetCode] 29. 两数相除
    [LeetCode] 27. 移除元素
    转:畅享云时代:开发者必备的8个最佳云端集成开发环境
    转:前端集锦:十款精心挑选的在线 CSS3 代码生成工具
    转:So Easy!让开发人员更轻松的工具和资源
    转:Backbone与Angular的比较
  • 原文地址:https://www.cnblogs.com/CKboss/p/3350869.html
Copyright © 2011-2022 走看看