zoukankan      html  css  js  c++  java
  • POJ 3349 Snowflake Snow Snowflakes



    Snowflake Snow Snowflakes
    Time Limit: 4000MSMemory Limit: 65536K
    Total Submissions: 27598Accepted: 7312

    Description

    You may have heard that no two snowflakes are alike. Your task is to write a program to determine whether this is really true. Your program will read information about a collection of snowflakes, and search for a pair that may be identical. Each snowflake has six arms. For each snowflake, your program will be provided with a measurement of the length of each of the six arms. Any pair of snowflakes which have the same lengths of corresponding arms should be flagged by your program as possibly identical.

    Input

    The first line of input will contain a single integer n, 0 < n ≤ 100000, the number of snowflakes to follow. This will be followed by n lines, each describing a snowflake. Each snowflake will be described by a line containing six integers (each integer is at least 0 and less than 10000000), the lengths of the arms of the snow ake. The lengths of the arms will be given in order around the snowflake (either clockwise or counterclockwise), but they may begin with any of the six arms. For example, the same snowflake could be described as 1 2 3 4 5 6 or 4 3 2 1 6 5.

    Output

    If all of the snowflakes are distinct, your program should print the message:
    No two snowflakes are alike.
    If there is a pair of possibly identical snow akes, your program should print the message:
    Twin snowflakes found.

    Sample Input

    2
    1 2 3 4 5 6
    4 3 2 1 6 5

    Sample Output

    Twin snowflakes found.

    Source

    CCC 2007 

    hash函数。。。3750ms。。。险过。。。
    #include <iostream>
    #include <cstdio>
    #include <cstring>
    #include <vector>

    using namespace std;

    struct ST
    {
       int a[6];
    };

    bool cmp(const ST x,const ST y)
    {
        bool flag=true;
        for(int i=0;i<6;i++)
        {
            flag=true;
            for(int j=0;j<6;j++)
            {
                if(x.a[j]!=y.a[(j+i)%6])
                {
                    flag=false;
                    break;
                }
            }
            if(flag) return true;
        }
        for(int i=0;i<6;i++)
        {
            flag=true;
            for(int j=0;j<6;j++)
            {
                if(x.a[5-j]!=y.a[(j+i)%6])
                {
                    flag=false;
                    break;
                }
            }
            if(flag) return true;
        }
        return false;
    }

    int main()
    {
        int n;
        ST A; bool flag=false;
        vector<ST> hash[17569];
        scanf("%d",&n);
        for(int i=0;i<n;i++)
        {
            int sum=0;
            for(int j=0;j<6;j++)
            {
                scanf("%d",&A.a[j]);
                sum+=A.a[j];
            }
            hash[sum%17569].push_back(A);
        }
        for(int i=0;i<17569;i++)
        {
            if(flag) continue;
            int nth=hash.size();
            for(int j=0;j<nth;j++)
            {
                for(int k=j+1;k<nth;k++)
                {
                    if(cmp(hash[j],hash[k]))
                    {
                        puts("Twin snowflakes found.");
                        flag=true;
                        break;
                    }
                }
            }
        }
        if(flag==false)
            puts("No two snowflakes are alike.");
        return 0;
    }
    * This source code was highlighted by YcdoiT. ( style: Codeblocks )

  • 相关阅读:
    大牛都是这样写测试用例的,你get到了嘛?
    炸!分享美团面试关于selenium的面试题
    功能测试如何快速转向自动化测试?
    接口测试之深入理解HTTPS
    Linux之用户和权限
    Hash函数及其应用
    用代码控制网络断开与重连
    Windows Azure初体验
    JS跨域知识整理
    最大子序列和问题
  • 原文地址:https://www.cnblogs.com/CKboss/p/3350869.html
Copyright © 2011-2022 走看看