zoukankan      html  css  js  c++  java
  • HDOJ 1532 Drainage Ditches

     同样的题目我竟然连续写了3遍        =。=lll人艰不拆

    Drainage Ditches

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 6974    Accepted Submission(s): 3295


    Problem Description
    Every time it rains on Farmer John's fields, a pond forms over Bessie's favorite clover patch. This means that the clover is covered by water for awhile and takes quite a long time to regrow. Thus, Farmer John has built a set of drainage ditches so that Bessie's clover patch is never covered in water. Instead, the water is drained to a nearby stream. Being an ace engineer, Farmer John has also installed regulators at the beginning of each ditch, so he can control at what rate water flows into that ditch. 
    Farmer John knows not only how many gallons of water each ditch can transport per minute but also the exact layout of the ditches, which feed out of the pond and into each other and stream in a potentially complex network. 
    Given all this information, determine the maximum rate at which water can be transported out of the pond and into the stream. For any given ditch, water flows in only one direction, but there might be a way that water can flow in a circle. 
     

    Input
    The input includes several cases. For each case, the first line contains two space-separated integers, N (0 <= N <= 200) and M (2 <= M <= 200). N is the number of ditches that Farmer John has dug. M is the number of intersections points for those ditches. Intersection 1 is the pond. Intersection point M is the stream. Each of the following N lines contains three integers, Si, Ei, and Ci. Si and Ei (1 <= Si, Ei <= M) designate the intersections between which this ditch flows. Water will flow through this ditch from Si to Ei. Ci (0 <= Ci <= 10,000,000) is the maximum rate at which water will flow through the ditch.
     

    Output
    For each case, output a single integer, the maximum rate at which water may emptied from the pond. 
     

    Sample Input
    5 4
    1 2 40
    1 4 20
    2 4 20
    2 3 30
    3 4 10
     

    Sample Output
    50
     

    Source
     

    Recommend
    lwg
     



    #include <iostream>
    #include <cstdio>
    #include <cstring>
    #include <queue>

    using namespace std;

    const int MaxV=10000,MaxE=10000;
    const int INF=0x3f3f3f3f;

    struct Edge
    {
        int to,next,flow;
    }E[MaxE];

    int Adj[MaxV],dist[MaxV],Size,src,sink;  bool vis[MaxV];

    void Init()
    {
        Size=0;
        memset(Adj,-1,sizeof(Adj));
    }

    void Add_Edge(int u,int v,int c)
    {
        E[Size].to=v; E[Size].next=Adj; E[Size].flow=c; Adj=Size++;
        E[Size].to=u; E[Size].next=Adj[v]; E[Size].flow=0; Adj[v]=Size++;
    }

    void bfs()
    {
        memset(vis,false,sizeof(vis));
        memset(dist,0,sizeof(dist));
        queue<int> q;
        q.push(src); vis[src]=true;
        while(!q.empty())
        {
            int u=q.front(); q.pop();
            for(int i=Adj;~i;i=E.next)
            {
                int v=E.to;
                if(E.flow&&!vis[v])
                {
                    dist[v]=dist+1;
                    q.push(v);
                    vis[v]=true;
                }
            }
        }
    }

    int dfs(int u,int delta)
    {
        if(u==sink)
        {
            return delta;
        }
        else
        {
            int ret=0;
            for(int i=Adj;~i&&delta;i=E.next)
            {
                int v=E.to;
                if(E.flow&&dist[v]==dist+1)
                {
                    int dd=dfs(v,min(delta,E.flow));
                    E.flow-=dd; E[i^1].flow+=dd;
                    ret+=dd; delta-=dd;
                }
            }
            return ret;
        }
    }

    int maxflow()
    {
        int ret=0;
        while(true)
        {
            bfs();
            if(!vis[sink]) return ret;
            ret+=dfs(src,INF);
        }
    }

    int main()
    {
        int n,m;
        while(cin>>n>>m)
        {
            Init();
            for(int i=0;i<n;i++)
            {
                int a,b,c;
                cin>>a>>b>>c;
                Add_Edge(a,b,c);
            }
            src=1;sink=m;
            printf("%d ",maxflow());
        }
        return 0;
    }
    * This source code was highlighted by YcdoiT. ( style: Codeblocks )

  • 相关阅读:
    mysql 性能监控
    拼接字符
    mysql 存储 2
    mysql 存储过程
    flock
    readfile() file_get_content f
    url_encode和base64
    jsdetox反混淆js内容,解密前端加密参数
    前端加密之使用firefox来解密
    v to ray做渗透测试
  • 原文地址:https://www.cnblogs.com/CKboss/p/3350882.html
Copyright © 2011-2022 走看看