zoukankan      html  css  js  c++  java
  • POJ 1273 Drainage Ditches



    Drainage Ditches
    Time Limit: 1000MSMemory Limit: 10000K
    Total Submissions: 49739Accepted: 18863

    Description

    Every time it rains on Farmer John's fields, a pond forms over Bessie's favorite clover patch. This means that the clover is covered by water for awhile and takes quite a long time to regrow. Thus, Farmer John has built a set of drainage ditches so that Bessie's clover patch is never covered in water. Instead, the water is drained to a nearby stream. Being an ace engineer, Farmer John has also installed regulators at the beginning of each ditch, so he can control at what rate water flows into that ditch. 
    Farmer John knows not only how many gallons of water each ditch can transport per minute but also the exact layout of the ditches, which feed out of the pond and into each other and stream in a potentially complex network. 
    Given all this information, determine the maximum rate at which water can be transported out of the pond and into the stream. For any given ditch, water flows in only one direction, but there might be a way that water can flow in a circle. 

    Input

    The input includes several cases. For each case, the first line contains two space-separated integers, N (0 <= N <= 200) and M (2 <= M <= 200). N is the number of ditches that Farmer John has dug. M is the number of intersections points for those ditches. Intersection 1 is the pond. Intersection point M is the stream. Each of the following N lines contains three integers, Si, Ei, and Ci. Si and Ei (1 <= Si, Ei <= M) designate the intersections between which this ditch flows. Water will flow through this ditch from Si to Ei. Ci (0 <= Ci <= 10,000,000) is the maximum rate at which water will flow through the ditch.

    Output

    For each case, output a single integer, the maximum rate at which water may emptied from the pond.

    Sample Input

    5 4
    1 2 40
    1 4 20
    2 4 20
    2 3 30
    3 4 10

    Sample Output

    50

    Source

    USACO 93 

    最大流Dinic算法模板:
    #include <iostream>
    #include <cstdio>
    #include <cstring>
    #include <queue>

    using namespace std;

    const int INF=0x3f3f3f3f;
    const int MaxV=500,MaxE=10000;

    struct Edge
    {
        int to,next,c;
    };

    Edge E[MaxE+10];
    int Adj[MaxV+10],Size;

    void Init()
    {
        Size=0;
        memset(Adj,-1,sizeof(Adj));
    }

    void Add_Edge(int u,int v,int w)
    {
        E[Size].to=v;
        E[Size].next=Adj;
        E[Size].c=w;
        Adj=Size++;
        E[Size].to=u;
        E[Size].next=Adj[v];
        E[Size].c=0;
        Adj[v]=Size++;
    }

    bool vis[MaxV+10];   int dist[MaxV+10];
    int src,sink;

    void bfs()
    {
        memset(dist,0,sizeof(dist));
        queue<int> q;
        q.push(src);vis[src]=true;
        while(!q.empty())
        {
            int u=q.front();
            q.pop();
            for(int i=Adj;~i;i=E.next)
            {
                int v=E.to;
                if(E.c&&!vis[v])
                {
                    q.push(v);
                    dist[v]=dist+1;
                    vis[v]=true;
                }
            }
        }
    }

    int dfs(int u,int delta)
    {
        if(u==sink)
        {
            return delta;
        }
        else
        {
            int ret=0;
            for(int i=Adj;~i&&delta;i=E.next)
            {
                int v=E.to;
                if(E.c&&dist[v]==dist+1)
                {
                    int dd=dfs(v,min(delta,E.c));
                    E.c-=dd; E[i^1].c+=dd;
                    delta-=dd; ret+=dd;
                }
            }
            return ret;
        }
    }

    int maxflow()
    {
        int ret=0;
        while(true)
        {
            memset(vis,false,sizeof(vis));
            bfs();
            if(!vis[sink]) return ret;
            ret+=dfs(src,INF);
        }
    }

    int main()
    {
        int n,m;
        while(scanf("%d%d",&n,&m)!=EOF)
        {
            Init();
            for(int i=0;i<n;i++)
            {
                int a,b,c;
                scanf("%d%d%d",&a,&b,&c);
                Add_Edge(a,b,c);
            }
            src=1,sink=m;
            printf("%d ",maxflow());
        }

        return 0;
    }
    * This source code was highlighted by YcdoiT. ( style: Codeblocks )

  • 相关阅读:
    一个贼基础的 编码解码方式
    SQL 中循环、for循环、游标
    sql中判断是否存在 数据库、表、存储过程、函数
    sql 同步表或同步表的时候更改部分字段
    sql存储过程的建立
    POJ
    UCloud 的安全秘钥 (计蒜客初赛第五场)(待解决)
    UCloud 机房的网络搭建(计蒜客初赛第五场)
    2017 计蒜之道 初赛 第四场
    腾讯课堂的物理实验(2017计蒜客初赛第三场)
  • 原文地址:https://www.cnblogs.com/CKboss/p/3350885.html
Copyright © 2011-2022 走看看