zoukankan      html  css  js  c++  java
  • ZOJ 2297 Survival


    状压DP
    Survival

    Time Limit: 5 Seconds      Memory Limit: 32768 KB

    The King of Fighter 97 (KOF97) is an electronic game of wrestling type. Once it was fashionable among youths. The game is amused. However, playing by oneself is not as excited as with friends. Getting bored? Maybe you can alter to the survival mode.

    In the survival mode, you play as usual, but under quite unfair conditions: you must use your only character to beat all the other characters and Orichi as well (who is the BOSS)!!! How can you do that? We know that usually we will consume some HP of the character to beat one opponent. Although the character will recover some HP after beating one opponent, the amount of HP recovered is affected by the time you used, so it??s possible that the character lose some HP after one round. What??s worse, if the HP of your character is not enough for you to beat your opponent, you lose!

    Given the HP of your character you need to consume and the HP your character will recover if you win for every opponent, you are to determine whether you can clear the game.

    NOTE:
    1. The initial HP of your character is 100.
    2. You can challenge your opponents in any order except that Orichi is always the last one.
    3. If your HP falls BELOW zero after any fights (before recovery), you will get your mission failed. 4. Your HP should never exceed 100.


    Input

    There are multiple test cases, which are separated by a blank line. The first line of each test case is a single integer N (1 <= N <= 20), gives the number of opponents you need to beat. The following N ?C 1 lines each contain two integers C and R (0 <= C, R <= 100), where C for the HP you need to consume to beat the opponent and R for the HP recovered after you beat the opponent. The last line contains only one integer P (0 <= P <= 100), describing the HP you need to consume to beat Orichi.


    Output

    For each test case, generate one line of output: if you can clear the game, print "clear!!!" otherwise print "try again" (both without quotations).


    Sample Input

    3
    50 50
    40 40
    70


    Sample Output

    clear!!!



    Author: JIAO, Xiantao
    Source: ZOJ Monthly, February 2005 


    #include <iostream>
    #include <cstdio>
    #include <cstring>

    using namespace std;

    const int INF=0x3f3f3f3f;

    int dp[1100000];

    int main()
    {
        int n;
    while(cin>>n)
    {
    //    cout<<sizeof(dp)/(1024.*1024)<<endl;
        int a[30],b[30],boss;
        memset(dp,0,sizeof(dp));
        dp[0]=100;

        for(int i=0;i<n-1;i++)
        {
            cin>>a>>b;
        }
        cin>>boss;

        int m=(1<<(n-1))-1;
        for(int i=0;i<=m;i++)
        {
            for(int j=0;j<n-1;j++)
            {
                if(!(i&(1<<j))&&dp>=a[j])
                {
                    int s=dp-a[j]+b[j];
                    if(s>dp[i|(1<<j)]) dp[i|(1<<j)]=s;
                    if(dp[i|(1<<j)]>100) dp[i|(1<<j)]=100;
                }
            }
        }

        if(dp
    >=boss)
            puts("clear!!!");
        else
            puts("try again");

    }
        return 0;
    }

  • 相关阅读:
    嵌入式驱动开发之sensor---sensor 图形传感器调试
    时下世界上最先进的液晶面板技术---ips
    多媒体开发之rtp 打包发流---udp 丢包问题
    多媒体开发之rtp 打包发流---同网段其他机子sdp 播放不了
    AutoCAD LoadLibrary Failed with error 126 Message
    OpenCV获取与设置像素点的值的几个方法
    四元数与旋转
    圆点博士小四轴主程序状态机结构
    四元数(Quaternion)和旋转 +欧拉角
    PID控制算法
  • 原文地址:https://www.cnblogs.com/CKboss/p/3350920.html
Copyright © 2011-2022 走看看