zoukankan      html  css  js  c++  java
  • HDOJ 2795 Billboard


    线段树。。。。。

    Billboard

    Time Limit: 20000/8000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 7316    Accepted Submission(s): 3278


    Problem Description
    At the entrance to the university, there is a huge rectangular billboard of size h*w (h is its height and w is its width). The board is the place where all possible announcements are posted: nearest programming competitions, changes in the dining room menu, and other important information.

    On September 1, the billboard was empty. One by one, the announcements started being put on the billboard.

    Each announcement is a stripe of paper of unit height. More specifically, the i-th announcement is a rectangle of size 1 * wi.

    When someone puts a new announcement on the billboard, she would always choose the topmost possible position for the announcement. Among all possible topmost positions she would always choose the leftmost one.

    If there is no valid location for a new announcement, it is not put on the billboard (that's why some programming contests have no participants from this university).

    Given the sizes of the billboard and the announcements, your task is to find the numbers of rows in which the announcements are placed.
     

    Input
    There are multiple cases (no more than 40 cases).

    The first line of the input file contains three integer numbers, h, w, and n (1 <= h,w <= 10^9; 1 <= n <= 200,000) - the dimensions of the billboard and the number of announcements.

    Each of the next n lines contains an integer number wi (1 <= wi <= 10^9) - the width of i-th announcement.
     

    Output
    For each announcement (in the order they are given in the input file) output one number - the number of the row in which this announcement is placed. Rows are numbered from 1 to h, starting with the top row. If an announcement can't be put on the billboard, output "-1" for this announcement.
     

    Sample Input
    3 5 5
    2
    4
    3
    3
    3 
     

    Sample Output
    1
    2
    1
    3
    -1
     

    Author
    hhanger@zju
     

    Source
     

    Recommend
    lcy



    #include <iostream>
    #include <cstdio>
    #include <cstring>

    using namespace std;

    #define lson l,m,rt<<1
    #define rson m+1,r,rt<<1|1
    const int maxn=222222;
    int h,w,n,x,MAX[maxn<<2];

    void pushUP(int rt)
    {
        MAX[rt]=max(MAX[rt<<1],MAX[rt<<1|1]);
    }

    void build(int l,int r,int rt)
    {
        MAX[rt]=w;
        if(l==r) return;
        int m=(l+r)>>1;
        build(lson); build(rson);
    }

    int query(int x,int l,int r,int rt)
    {
        if(l==r)
        {
            MAX[rt]-=x;
            return l;
        }
        int m=(l+r)>>1;
        int ret=(x<=MAX[rt<<1]) ? query(x,lson):query(x,rson);
        pushUP(rt);
        return ret;
    }

    int main()
    {
    while(scanf("%d%d%d",&h,&w,&n)!=EOF)
    {
        if(h>n) h=n;
        build(1,h,1);
        while(n--)
        {
            scanf("%d",&x);
            if(x>MAX[1]) puts("-1");
            else printf("%d ",query(x,1,h,1));
        }
    }

        return 0;
    }


  • 相关阅读:
    Appium自动化环境搭建
    真机Android 8.0版本以上uiautomator定位元素-Unsupported protocol: 2/Unexpected error while obtaining UI hierarchy错误处理
    rsa非对称加密
    QT使用OpenSSL的接口实现RSA的加密解密
    lua安装后其他库使用产生问题解决方法
    log4cpp的使用描述
    std::function和std::bind
    C++11线程睡眠的方式
    高精度计时器
    如何解决TCP拆包粘包问题
  • 原文地址:https://www.cnblogs.com/CKboss/p/3350935.html
Copyright © 2011-2022 走看看