zoukankan      html  css  js  c++  java
  • HDOJ 1208 Pascal's Travels



    Pascal's Travels

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 1296    Accepted Submission(s): 570


    Problem Description
    An n x n game board is populated with integers, one nonnegative integer per square. The goal is to travel along any legitimate path from the upper left corner to the lower right corner of the board. The integer in any one square dictates how large a step away from that location must be. If the step size would advance travel off the game board, then a step in that particular direction is forbidden. All steps must be either to the right or toward the bottom. Note that a 0 is a dead end which prevents any further progress. 


    Consider the 4 x 4 board shown in Figure 1, where the solid circle identifies the start position and the dashed circle identifies the target. Figure 2 shows the three paths from the start to the target, with the irrelevant numbers in each removed. 

    HDOJ 1208 Pascal39;s Travels - qhn999 - 码代码的猿猿

    Figure 1

    HDOJ 1208 Pascal39;s Travels - qhn999 - 码代码的猿猿

    Figure 2
     

    Input
    The input contains data for one to thirty boards, followed by a final line containing only the integer -1. The data for a board starts with a line containing a single positive integer n, 4 <= n <= 34, which is the number of rows in this board. This is followed by n rows of data. Each row contains n single digits, 0-9, with no spaces between them.
     

    Output
    The output consists of one line for each board, containing a single integer, which is the number of paths from the upper left corner to the lower right corner. There will be fewer than 2^63 paths for any board. 
     

    Sample Input
    4
    2331
    1213
    1231
    3110
    4
    3332
    1213
    1232
    2120
    5
    11101
    01111
    11111
    11101
    11101
    -1
     

    Sample Output
    3
    0
    7
    Hint
    Hint
    Brute force methods examining every path will likely exceed the allotted time limit. 64-bit integer values are available as "__int64" values using the Visual C/C++ or "long long" values using GNU C/C++ or "int64" values using Free Pascal compilers.
     

    Source
     

    Recommend
    mcqsmall
     


    #include <iostream>
    #include <cstdio>
    #include <cstring>

    using namespace std;

    int mp[40][40];
    unsigned long long int dp[40][40];
    int n;

    int main()
    {
    while(scanf("%d",&n)!=EOF&&n!=-1)
    {
        char str[40];
        for(int i=0;i<n;i++)
        {
            scanf("%s",str);
            for(int j=0;j<n;j++)
            {
                mp[j]=str[j]-'0';
            }
        }


        memset(dp,0,sizeof(dp));

        int i,j;
        dp[0][0]=1;

        for(i=0;i<n;i++)
        {
            for(j=0;j<n;j++)
            {
                if(mp[j]!=0)
                {
                    if(i+mp[j]<n)
                    {
                        dp[i+mp[j]][j]+=dp[j];
                    }
                    if(j+mp[j]<n)
                    {
                        dp[j+mp[j]]+=dp[j];
                    }
                }
            }
        }

        printf("%I64d ",dp[n-1][n-1]);
    }

        return 0;
    }

  • 相关阅读:
    元素的ID和Name有什么区别???[转自"天道酬勤"]
    招聘时会问到的问题
    关于asp.net开发B/S应用系统的思索和讨论
    软件文档知多少?
    C# 编码规范和编程好习惯
    [转]多层结构来开发ASP.NET程序
    ASP.NET页面间的传值的几种方法
    为sql server 表数据生成创建的储存过程(生成insert 脚本)
    XHTML+CSS应用教程——利用CSS实现双语导航条
    XHTML+CSS应用教程——CSS实现文字的双影
  • 原文地址:https://www.cnblogs.com/CKboss/p/3350956.html
Copyright © 2011-2022 走看看