zoukankan      html  css  js  c++  java
  • ZOJ 3623 Battle Ships


    Battle Ships

    Time Limit: 2 Seconds      Memory Limit: 65536 KB

    Battle Ships is a new game which is similar to Star Craft. In this game, the enemy builds a defense tower, which has L longevity. The player has a military factory, which can produce N kinds of battle ships. The factory takes ti seconds to produce the i-th battle ship and this battle ship can make the tower loss li longevity every second when it has been produced. If the longevity of the tower lower than or equal to 0, the player wins. Notice that at each time, the factory can choose only one kind of battle ships to produce or do nothing. And producing more than one battle ships of the same kind is acceptable.

    Your job is to find out the minimum time the player should spend to win the game.

    Input

    There are multiple test cases. 
    The first line of each case contains two integers N(1 ≤ N ≤ 30) and L(1 ≤ L ≤ 330), N is the number of the kinds of Battle Ships, L is the longevity of the Defense Tower. Then the following N lines, each line contains two integers i(1 ≤ i ≤ 20) and li(1 ≤ li ≤ 330) indicating the produce time and the lethality of the i-th kind Battle Ships.

    Output

    Output one line for each test case. An integer indicating the minimum time the player should spend to win the game.

    Sample Input

    1 11 12 101 12 53 1001 103 2010 100

    Sample Output

    245
    Author: FU, Yujun
    Contest: ZOJ Monthly, July 2012


    二分+完全背包


    #include <iostream>
    #include <cstring>

    using namespace std;

    int ti[30];
    int li[30];
    int N,L;

    bool jj(int x)
    {
        int dp[10100];
        memset(dp,0,sizeof(dp));

        for(int i=0;i<N;i++)
        {
            for(int j=ti;j<=x;j++)
            {
                dp[j]=max(dp[j],dp[j-ti]+(x-j)*li);
            }
        }

        int OK=0;
        for(int i=x;i>=0;i--)
        {
            if(dp>=L)
            {
                OK=1;
                break;
            }
        }

        if(OK==1) return true;
        else  return false;

    }

    int main()
    {
    while(cin>>N>>L)
    {
        for(int i=0;i<N;i++)
            cin>>ti>>li;

        int ma=10000;
        int mi=1;

        while(ma-1!=mi)
        {
            int mid=(ma+mi)/2;
            if(jj(mid))
            {
                ma=mid;
            }
            else
            {
                mi=mid;
            }
        }

        cout<<ma<<endl;

    }

        return 0;
    }

  • 相关阅读:
    vue移动端适配问题
    excel 表格数据转json格式
    常用快捷键
    微信公众号监听返回事件
    总结css常用方法
    封装axios
    初学angular项目中遇到的一些问题
    jquery项目中一些常用方法
    怎样做ie兼容性
    vue事件修饰符
  • 原文地址:https://www.cnblogs.com/CKboss/p/3351029.html
Copyright © 2011-2022 走看看